John Thorn Maps - blank tiles

Craig shared this problem 8 months ago
Solved

An issue has developed with both John Thorn Maps I downloaded from the Locus, Store (Scotland - Highland and Scotland - Lowlands) When zooming in, the maps fail to render properly resulting in blank tiles, sometimes multiple blank tiles.


This problem happens with or without hill shading enabled.and which theme is selected has no impact.


The issue does not occur on other maps I use such as Locus maps or OpenAndroMaps, some of these maps have larger file sizes.


I've tried deleting all temporary files and also deleting the John Thorn maps and reinstalling them without any change in behaviour.


I'm using the latest version of Locus Maps Pro but I tested the problem in Locus V4 and it exists there also.


I am using a Samsung Galaxy Note 10 + which has 12gb of memory

Replies (2)

photo
1

Hello,

I'm sorry for trouble. Could I kindly ask you for GPS coordinates (or for example name of a nearby city) of a problematic area. We'll check the map.

Thanks, Petr

photo
1

Hi Petr,


I've attached a screenshot with the Grid Reference visible top left. The blank tiles change each time I zoom in or out of the map so it's not an issue with a specific tile as such

photo
1

Thank you for the screenshot. I'm in touch with John Thorn (the map creator) and we'll prepare a fix version of the mentioned map.

Thanks, Petr

photo
1

Thanks for the update Petr. I'm finding the same behaviour in multiple locations for both the Highland and Lowland John Thorn Maps to the point where both are unusable.

photo
1

The recent update to 3.51.2 appears to have resolved the issue, so it appears the problem was LM related and not map related?


One observation following the update is that zooming out of any map (John Thorn and LoMaps) has some latency and it takes time to redraw the map tiles but it does work without leaving any blank tiles.


Zooming in however is much better. Map tiles render quickly with no blank tiles being displayed.

photo
1

Hi,

I'm sorry for the late response. Anyway, there are really changes in 3.51.2 that should fix this issue. Please update on the latest version.

Thank you

Petr

photo
photo
1

I have again the same problem with topographic vector maps for Finland. This problem was already fixed around October 2020, but happened again (with same tiles, too) after updating Locus to the recent version 3.51.0.


BR,


Pertti

photo
1

Hello,


Just for reference my previous ticket of similar problem:

https://help.locusmap.eu/ticket/22553


BR, Pertti

photo
1

That link no longer exists or is broken.

photo
1

Hello Craig


Below is copy of my previous report from October. I do confirm that the same, already fixed problems exist again. I have updated the report details.


I have found a problem with offline mapsforge vector maps installed into Locus Map Pro. Some tiles of the vector map do not draw correctly when zoomed into the map. SImilar problems has been reported years ago but probably not for veector maps.


Below is how the problem can be recreated using Mapsforge OpenMaps.eu.


From the page https://openmaps.eu/mapsforgedownloadinstallGermany (southeast)map to Locus. Also, install appropriate render theme like Locus Map (normal and large screen size). Use Locus Quick Map swith to select Germany Openmaps eu Europe. Center the map if current location is outside of the map. Also select the OpenMaps_V7 Maptheme. Zoom the map to 70 km -100 km level. Only three parts of Germany are shown: Vilshofen an der Donau, Berchtesgaden, and tiny area at Salzach. See the screenshot Locus_vector_map_problem_Germany_1.png. Zoom into the southern Salzach area at, e.g., N 47° 50.772' E 013° 00.145'. See the screenshot Locus_vector_map_problem_Salzach_1.png. Zoom in into level 100 m until suddenly the southern part vanishes. See the screenshot Locus_vector_map_problem_Salzach_2.png. If zoomed out, the southern part remains still invisible, until appears after a couple of zoom out step.


The same problem can be found in numerous places at the other parts of the mapsforge Germany map.


The same problem also exists with topographic offline map of Finland available free at at https://kartat.hylly.org/(in Finnish only); "Asenna kartta Locukseen" for the map install and "Asenna kuvaustekniikka Locukseen" for the render theme. See the screenshot Locus_vector_map_problem_Finland.png for an example of similar problem but with a vector map from other source (the screenshot is from a popular outdoors area near my home town).


System:


- Locus Map Pro 3.51.1 at Android 11 4.14.113 on Samsung Galaxy S10e


In the previous report the problem existed also with: Locus Map Pro 3.49.0 at Memu 7.2.7 on Windows 10 PC (fresh install)


With best regards,


Pertti

photo
Leave a Comment
 
Attach a file