Minor problem LM4 and accu optimization on Android 10

c.s.g. shared this problem 5 months ago
Solved

Hello,

after flashing my Samsung Galaxy S4 with LineageOS 17.1 (Android 10) I have a minor problem with the accu optimization after installing LM 4.0 Gold. Not realy with accu optimization but with the coresponding hint when starting track recording.


I. e. when I start track recording in LM 4.0 I get the hint, that accu optimization is activ for LM 4.0 (see screenshot 1). But if I follow the link, Andoid 10 tells me, that LM 4.0 is not optimized for accuu optimization and even accu optimization is not available for LM 4.0 (see screenshot 2). Android 10 seems to deactivate accu optimization for LM 4.0 automatically during installation of LM 4.0. So, when I click on the LM icon in the settings nothing happens.


After a longer test, it seems to be true that accu optimization is turned off,, because I had no problem recording a longer track even the screen turned off. But I am not able to get rid of the hint in screenshot 1 when starting a new track.

c.s.g.

Replies (6)

photo
1

confirm behavior on my


Samsung XCover 4s Android 10

photo
1

Hi guys,

as I see, this hint appears in two cases that is Locus Map able to detect

  1. system is set to "Power save mode"
  2. application is "Battery optimized"

Maybe you use "power save" mode on your device? Even with this mode enabled, there is no problem with recording? Nice surprise to me because it definitelly caused a problems on older Android devices ...

photo
1

Hi Menion,

probably the "Power save mode" was enabled. I am not quite sure.

I solved the "problem" in the way I upgraded to LinegeOS 18.1 (Android 11) on my Samsung Galaxy S4 and the message disapear as expected when setting the corresponding "battery optimized" settings for Locus LM 4.x.

"Power save mode" is disabled too.

photo
1

Hello,

hmm, so some issue in the LineageOS system? Interesting. Balloni, you use also LineageOS or PowerSafe mode active?

photo
1

i use


Samsung default android10

with basically the lowest optimization known to me

and especially LM and LM Pro are additionally excluded

e25e093803b87d39e804e2efb7bb2f55f3e691383dd18948ba897fc1c73aaca2a62354bbe257b1c38b482396c25bf2e5

photo
1

Interesting.

I've added unto long-click on the main menu option "Device info", where will be visible current system setup. So you will see. Both values set to false => no visible warning.

/c466fe340db6032cda863744a422eff3

photo
1

Hello menion

it's exactly like your screnshot, but i can't find a setting to turn off the battery optimization in my device

photo
1

Hmm and isn't settings you posted on screenshot below exactly opposite? I think that "enabled" means = not optimized. May you try it?

/8cfb85fec449c91eec398b58ba3a1fec

photo
1

323e0a1d23e31bd29feb520f38c980ecHello menion,

i don´t think so, but i couldn´t test it because some Apps, also both Locus apps are grayed and the switch can´t be changed.

Till now i found no setting to enlighten them

photo
1

Hey, this is really interesting. I have exactly the same problem on my own device, but I thought it is just because I use some special kind of development version. Weird ...

---

Some testing ... seems it is affected by the "Device administrator" option. Once I've disabled it, this setting may be changed. So this probably means, that apps that are "device admins", are automatically excluded from battery optimization (it make sense). If so, detection in the track recording screen is incorrect, hmm ...

photo
1

Hello menion

V4.1.0

the warning remains,

now both values are displayed as "true"

photo
1

Hi, hehe progress :).

And when you disable "Power save mode" in your device? Because I did nothing about this settings.

photo
1

it was disabeled, also after new update


after restart of device warning is gone, so solved for me thanks


- power safe mode >false

- Battery optimized > true

photo
1

After restart? On Android are sometimes really weird mysteries :/.

photo
Leave a Comment
 
Attach a file