Action Task "track_record" bug - and improvement needed

Tapio shared this problem 39 days ago
Solved

Hi Menion,


I am doing Tasker triggered track recordings with Action Tasks. Basically, when I leave home it starts recording. But nothing is perfect, sometimes there's faulty recordings around my home.


https://github.com/asamm/locus-api/wiki/Action-tasks-(Broadcasts)


Therefore: If track is shorter than 100m (I can pull that info via the Tasker plugin) I want to cancel recording.


I.e., stop recording without saving the track. This is currently impossible.


I was trying autosave false...:

"tasks: { track_record : { action: "stop", auto_save: false } }"


Bug? Auto save "false" does not make a difference to true. It saves the track without an intermediate dialog.


Suggestion: Add a "cancel" option or better a command for automation goodness 😀 So we have start/stop/pause/toggle/cancel


Thanks for consideration...

Comments (1)

photo
1

Hello Tapio,

hmm currently enabled "auto-save" value from the recording profile always wins. That causes the issue you write about.

So changes to next version:

  • when "autosave" will be defined in action, it wins now. If not defined, the value from the recording profile will be used
  • added new action "discard"

I've updated docs, so check it there. I've also not tested this! so check it please in the next version and let me know if all works as expected. Thanks and enjoy automation goodness :)


Menion

photo
1

I cannot express how thankful I am. Will test of course.

photo
2

Discard works well.

photo