Unexpected tracks shown and cannot be turned off

Ajay shared this question 7 days ago
Answered

Locus Map Pro, 3.52.1

on Android 8.1

after clean installation the application shows tracks everywhere, in every country where I look, as soon as I zoom in down to 3mi range. However !! the track manager shows zero tracks (visible and loaded, I haven't imported or created any), and a complete reinstall after a deletion of the whole Locus folder and a fresh download from Goog Play has not solved the problem. These tracks aren't anything I have ever seen before, and I am sure they are not located elsewhere on my phone.


I can't make sense of this. Help please !!

Comments (6)

photo
1

A screenshot would be helpful.

One possibility is that these "tracks" are "within" the selected map and are shown because the used theme of the map is configured that way.

For example the OAM germany north map have official "tracks for bycicles" integrated and these "tracks" can be make visible / unvisible in the configuration of the coressponding "elevate"-theme.

So these "tracks" are not stored in locus but are part of the use map.

photo
1

Thanks for responding,


these tracks show in the OSM classic map, but also in the LOMap which I downloaded in order to make sure it's not only showing in one (type of) map. The tracks I see do not look like "official tracks", but I could be wrong. One sample screen shot is attached, showing various track lines in blue, red, orange, etc.

photo
1

missing screenshot

photo
1

I think I can simulate your "problem":

(1.) Using LoMap "Germany South" (Sccreenshot 1)

(2.) Using theme "Wandern & Radfahren" für LoMap "German South" (Screenshot 2)

(3.) Selecting the shown settings in theme "Wandern & Radfahren" (Screenshot 3) leads to the view in map (Screenshot 4).

(4.) Selecting the shown settings in theme "Wandern & Radfahren" (Screenshot 5) leads to the view in map (Screenshot 6).

HTH.

photo
1

Thanks again, I see what you mean.


May be it is related, but unfortunately it doesn't explain my problem. I am using the OSM classic map (this is where the problem showed first), and when one tries to select map themes, the message shows is: "no map with themes is active", in other words this map shows the problem, but it does not support themes. Again, please remember, I am showing the problem with a completely clean / reset version of Locus. The only thing I did change before the problem ocured is adding one Lomap for offline use.


Strange no ? where do these strange tracks come from if not from the installer package ? and where can they be switched off (if that's all it takes ?)

photo
1

Hi Ajay,

the colored routes are part of the map (they are included in the OSM data from which LoMaps are rendered), they are not part of Locus track database. If you want to hide them, uncheck the cycling routes, hiking and MTB routes in the LoMap's hiking/biking theme. OSM classic is a raster map - therefore it doesn't contain any themes.