Problem with WMS satellite images

Piergiorgio Navone shared this problem 4 months ago
Known

I cannot load the following WMS resource:

http://opengis.csi.it/mp/regp_agea_2018?service=WMS&request=GetCapabilities&version=1.3.0


BTW, the same map is also available as WMTS: do you plan to supportr WMTS in LocusMap?

http://opengis.csi.it/mp/regp_agea_2018?service=WMTS&request=GetCapabilities

Replies (6)

photo
1

Hello Piergiorgio,

I'm testing WMS version and also WMTS (that already works in Locus Map Free/4) and in both cases, map is correctly added into the app, but no content is visible on the screen (server return empty map tiles). Did you tried the map in any alternative app to verify it's functionality like QGis? Do you also know, where should be map tiles visible, in which area? Thanks.

photo
1

Hi,

yes, I tried in QGis and it works.

In QGis I used UTM (EPSG:32632).

In Locus I tried both UTM and Pseudo-Mercator (EPSG:3857).

Il giorno mar 13 lug 2021 alle ore 12:40 Locus Map <locus.map@asamm.com> ha scritto:

photo
1

Hi, thanks for the QGIS test. I'm trying it as well and have a different experience. With EPSG set to 32632 or 3857, the map does not work. It works only with 4326. I'm anyway not a QGIS master so I'm probably doing something wrong. But! with EPSG set to 4326 in the Locus Map app, it works in the app as well. May you please give it a try? Thanks.

photo
1

Hi,

yes. With 4326 it works in LocusMap also for me.

Thanks

Il giorno mar 13 lug 2021 alle ore 22:10 Locus Map <locus.map@asamm.com> ha scritto:

photo
1

Well, yet it works, technically.

But with EPSG:4326 the images are heavily reprojected with a distortion effect.

Here you can see a screenshot of LocusMap with EPSG:4326 and the same WMS map shown in QGis with the "native" EPSG, that is the same EPSG of the map and so without the need for reprojection.

Il giorno mer 14 lug 2021 alle ore 09:06 Piergiorgio Navone <pg.navone@gmail.com> ha scritto:

Hi,

yes. With 4326 it works in LocusMap also for me.

Thanks

Il giorno mar 13 lug 2021 alle ore 22:10 Locus Map <locus.map@asamm.com> ha scritto:

photo
1

Hello,

interesting that I do not have distortion for 4326 at all. Anyway, I'm thinking about the reason why other projections do not work, and seems I have an idea. It anyway needs a bigger touch to the WMS system in the app. I've added this as a task to my "Improve WMS/WMTS list" and look at it later. Thanks for understanding.

Menion

Leave a Comment
 
Attach a file