Transferring the main directory to a new folder, V 4.3

David Galloway shared this problem 42 days ago
In Progress

At the end of the latest blog post there’s talk about the need to move Locus to a private folder. I used the new option in Settings/Miscellaneous and while Locus works as normal, I have lost my Presets and Tracks. Advice on how to link them to the revised file location would be appreciated.


Thanks


David

Replies (6)

photo
1

confirm behavior


With X-plore I see the newly created folder with content under android/data/menion.android.locus/files

Wolfgang


EDIT: import from yesterdays backup solved the problem..

but this cannot be the solution to the problem

photo
1

EDIT2:

i miss my mapitems, aren´t they part of a full backup ??

photo
1

Hi guys,

what exactly is the problem? You both used the new option to move the app main directory into the app private folder and it does not work? After restart, you miss any data? Did you checked if app really selected new directory as the default app directory. And balloni55 no, "mapItems" never was part of the backup system.

photo
1

Hello menion

# After restart, you miss any data?

Yes,

sorry in my first post i wrote "with content" it should be without content


#Did you checked if app really selected new directory as the default app directory

see screenshot

#"mapItems" never was part of the backup system

thanks, i didn´t know or forgeta1abfec3d12e5efa20fa411264d8946d

photo
1

Damn, this is quite serious problem.

Are mapItems still in the old original location or this old directory was (correctly) completely deleted?

Weird is, that only in case, old data are copied! (not moved) correctly, then app set it's directory to new location and remove old directory, not sooner. So in case, during copy will be any problem, task should be stopped and nothing should change/lost.

@David it is same problem? You miss Locus/data/presets directory in the new location as well as data stored in Locus/data/database?

photo
1

# then app set it's directory to new location and remove old directory

with me all data are also still in the old folders available and I think that is correct since I have installed LMP furthermore on the inner SD, installed on the same device

photo
1

Yes, Menion, I’m missing both Presets and Tracks and Routes. I can create new Presets ok and it does record what i have done and save it ok, but in an empty file.

photo
photo
1

Hi guys,

sorry for the delay in my answer. I was waiting if some more people will report the same issue or anyone in the team, but no other reported problems with the automatic transfer of directories between selected directories.

Application firstly copies data to a new directory and once it is all correctly done, it changes the app default directory and deletes the original directory. So I can't imagine, how the problem with missing directories may happen!

balloni55, you solved your issue thanks to the backup right? David, what about you? Were you able to locate the old directory, does it contain old tracks (in Locus/data/database/tracks.db file) and presets (in Locus/data/presets)?

photo
1

Hello menion

# I was waiting if some more people will report the same...

I think there are only a few users so far who have switched to the private folder.


# you solved your issue thanks to the backup right?

everything that the backup offers could be written back in this way.

I had to manually copy the following data from the old path that still exist

- custom screens

- mapithems

- geocaching

- photo_poi

Leave a Comment
 
Attach a file