New sensor manager in Locus Map, version 4.4 ( 23.9.2021+ )

Piotr Tymiński shared this problem 32 days ago
Solved

None of my smart bands (Miband 4, Galaxy Fit2) are visible now. Locus cannot find any BT device. Tried on 3 different phones and a tablet.

There was no problem with previous version.

Replies (4)

photo
1

MiBand 3 stop working with 4.4 version.

photo
2

Hi Piotr,

thanks for the bug report. You are correct. Seems that MiBand does not report itself as an HR monitor and because of this, Locus Map was unable to detect it. I believe I've fixed this issue. The new bug-fix version is just in preparation and will be most probably published today.

Jiří M. aka Menion

photo
1

Thanks. MiBand3 is working again.

photo
1

Just an afterthough, might be helpful for someone. After installing new or beta versions of Locus and pairing/re-pairing your HR smartband (MiBand, Galaxy Fit 2, etc) you may find out that Locus does not see any BT device. I played with various versions, including latest betas on 3 different phones, installing and reinstalling, upgrading and downgrading and always replicating the problem. I found out that turning on GPS while pairing BT device immediately rectified the problem . Don't ask me why. This was true for both smartbands. I replicated this behaviour several times. They paired immediately and afterwards were good to go.

photo
1

Thanks Piotr,

I had twice similar problem and turing BT off/on on the device solved the problem. Don't ask me why ... :/

Menion

photo
Leave a Comment
 
Attach a file