A minor niggle with geocache updates

JohnCNA shared this problem 6 months ago
Solved

I have LM 4.5.7 and wish to report a minor issue.

When I select Update Cache or Download Logs, the operations happen correctly and virtually instantly, but the progress spinner never stops spinning until the display page is dismissed.

7bb6c1f0a8e221dbc9eb7af553b0dab4

Replies (8)

photo
1

Hello,

we can't simulate your problem.

Please, can you describe your exact procedure to me, step by step?

And what geocache is this? Is it saved in the database, or just temporarily displayed?

Can you share a weblink of this cache with me?

Thank you for the clarification.


Zdenek, Locus team

photo
1

OK - first off, it only does this with opening a geocache from a GPX list. Doesn't matter what the source of the GPX is. Even if I capture Live in Locus and copy to a list. I never noticed that this does not happen with Live listings until you asked to document steps. I mostly just work off offline Lists.


Anyway, I uploaded a small sample GPX for testing.


Import the list and open it.

Select a geocache.

Displays on map.

Tap arrows in upper right to show map full screen.

Tap any one of the cache icons to open the half screen description card.

Select Update Cache or Download Logs.

Progress spinner spins continuously.


Actually if you skip the 'map full screen' step the problem still exists. It's just harder to notice because the dark gray top border overlays the black spinner.

photo
1

Hello,

I am sorry but we are unable to simulate your issue.

Please, wait for the next update - it should be out during next week - and if this error still will be there, write to me again.

Regards,


Zdenek, Locus team

photo
1

This is exactly the same problem as the one which I reported this week (and which is still Unprocessed).

photo
1

Hello,

please try to install the beta version from here: http://bit.ly/lmVersionsTest

Maybe the problem will disappear. If not, turn on the log to file:

  • After installation, run the app and long-press the main menu button ( 65ab74f02671fb4a2ceb0db7c0510f6e )
  • Choose the "Log to file"
  • Select the "Log to file"
  • Then close the app, wait for 10s and run it again.
  • Try to replicate all your issues (it will be logged this way)
  • After that, send me the logs which will be created in ".../Locus/logs"


Thank you.


Zdenek, Locus team

photo
1

I only see two files. Which should I choose?

photo
1

Hello, if you switch view mode to lines (not tiles), you will see the complete names of the files.

One file is standard, and one has an "All file access (AFA)" permission. But in this case, it doesn't matter which one you choose.

Except for AFA, the versions are the same.


Zdenek, Locus team

photo
1

Thank you. I was confused by the filename too - "MapGooglePlay" didn't seem to apply to Locus. Anyway, I installed the afa version and the problem is gone. I did not need to enable the expert option or logging.

photo
1

Hello,

I am glad it works. If the problem appear again, please feel free to write to me again. You can use this thread - it reopens if you write to it.

And for your information:

Google recently ordered us to remove AFA permissions from LM 4, so if you want to keep this functionality, turn off automatic updates on Google Play. The new version will always be available here, including the AFA variant: http://bit.ly/lmVersions

Regards,


Zdenek, Locus team

photo
1

Sorry I do not understand your information about "AFA permissions". I would hope that the error correction will be part of one of the next official LM4 updates on google play?

photo
1

The AFA means "All file access" - you can grant this permission to the version you have downloaded. But unfortunately Locus Map Pro never get it and now even Locus Map 4 have to remove it from the version which is in the Google Play. So if you want to preserve this permission available, you have to update Locus only from link I sent to you. If you don't need it, you can let everything as it is and when the next version will be available, Google play updates to it automatically.

Except AFA permission - both version are the same and non-AFA will be available in Google play in this version soon.

AFA is not related to your problem (or at least it shouldn't).


Zdenek, Locus team

photo
photo
1

As I did not want to try this on my "official" smartphone I tested it in a sandbox environment on my old device. In this environment the error was not reproducible. So let's hope that it is really fixed.

photo
1

Why is this happening? I installed the beta. Shows as 4.6.1.5 Beta in the About menu. Works fine. The next day, the version is 4.6.1 again. I reinstall the beta and use it. The next day it is reverted back to 4.6.1 again. The beta is being replaced with the previous version automatically every day. What could be causing this?

photo
1

Hello John

open Play Store on your phone, navigate to your installed apps > open LM4 and click top right 3-dot button > uncheck auto update.

from now all update have to be started manually by yourselfe

Wolfgang

photo
1

Ah, thanks. I have had auto update turned off forever, but forgot I had turned it on for the beta program.

photo
Leave a Comment
 
Attach a file