This object is in archive! 

Track recording problem - (Record only when moving and GPS ON for track recording)

Jacek J. shared this problem 16 months ago


Is it possible, that options "Record only when moving" and "GPS ON for track recording" causing problem with recording?

In a room hotel I turned on track recording and put smartphone in my pocket. It took me a few minutes before I walk outside the hotel. After few hundred meters I notticed that Locus doesn't record my trip and it didn't see my position, but after few seconds it started working (screenshot1). On te same trip, when I reached a view tower and stay there for a 40 minutes it happen again (screenshot2) and after screen activating it start record.

My phone: Samsung S20 FE 5G, Android 12

My phone settings for Locus:

  • Notification - full allowed
  • GPS - always allowed
  • Battery use - no limits

Locus settings:

  • Disable when app is hidden (Disables GPS when the screen is turned off or the app is minimized and GPS location is not required by any other function) - yes
  • GPS ON for track recording (Keeps GPS on during the track recording even if the recording is paused) - no
  • GPS ON for guidance (Keeps GPS on during guidance even if the app is minimized and screen is off.) - yes
  • Record only when moving - yes

Replies (5)


Maybe process looks like:

1. "Record only when moving = yes" - when we don't move, Locus stops recording

2. When recording is stopped, option "GPS ON for track recording = no" - it turn off GPS

3. When GPS is off - Locus doesn't know that we are moving and didn't start recording after we changed location.

4. Only when we turn on screen again and Locus start searching our GPS location it notice, that we changed location and Locus turn on the track recording.

What do You think?


"Disable when app is hidden" should be on "no".


Thanks Henk, but I'm afraid it will cause battery drain.

I think, I'll try set "GPS ON for track recording" ON.


So far so good.

Option "GPS ON for track recording"-ON is good solution for my problem. :-)


Good. I will try that setting allthough I have no battery problems.

Replies have been locked on this page!