Track recording: Add point behaviour

Guest shared this problem 4 months ago
Not a Problem

For some time the behaviour when adding a track point changed. Before a selection list opend where we could select from adding a plain/photo/audio/video point. Now we can define a default type by long tapping on the "add point" - icon, one of them is "Selection" which should offer the selection list like before. Now the problems and ideas which I noticed (Locus Map Pro):


1) "Selection" isn't working, neither with bottom nor with side panel. It directly opens "Add point (plain)"


2) With bottom panel, the icon of "Add point" adapts to the type of default action, so we can see at first sight whats the default behaviour => good! But this is not for side panel mode, here the icon stays the same. Please also adapt the icon.


3) In general long-tap actions are less intuitive since they are hidden actions. Right now for example people don't know how they are able to add a photo-point as they did before. I just by chance long tapped the icon and voila suddenly a Selection menu opens. My advice: Please make this "Set default action" dialog available in the "Track recording"-settings too, so it will be findable+adjustable also there.

Replies (3)

photo
1

Hi Sonny,

1) "Selection" isn't working, neither with bottom nor with side panel. It directly opens "Add point (plain)"

- long-tap the "add point" button and select "Selection" from the box. Next time the selection will open on a single tap

2) With bottom panel, the icon of "Add point" adapts to the type of default action, so we can see at first sight whats the default behaviour => good! But this is not for side panel mode, here the icon stays the same. Please also adapt the icon.

- good idea, I'll forward it to the devs

Point no. 3) relates to the no. 1). In this case the long-press menu serves only defining the one-tap default action. Original default is always the selection.

photo
1

Hi Sonny,


ad 1) I've tested the issue on the newest 3.59 (not yet available publicly) so please wait for it for a few more days.

photo
1

You were right, 1) is working with v3.59 again, thanks.

Leave a Comment
 
Attach a file