This object is in archive! 

Again: sensor BT 4 connection / data problems

Michael W shared this problem 2 years ago


I still have problems regarding my speed, cadence & HRM monitor.

Last update seems to solve (re-)connection problems, but with 4.8.1 no more data is displayed, sensor manager shows always: no valid data.

Even with HRM, which worked before and my heart is beating ;)

Further details in initial ticket by Ulrich K.:

Ticket status is solved (but issue is definitely not solved, at least for me), maybee therefore no updates in that ticket?

Or are you just busy right now and work rather on fixes than updating threads? Just used to your fast and good communication! ;)

If I take a look at newer tickets in general, there are some regarding sensors, BT & ANT+.

Maybee there is something messed up with sensor management in generell in the last Locus versions or any connection with the bigger android updates in the last weeks? Think there were some on multiple devices.

For example meanwhile my S20 FE is on Android 12 (KERNEL V 4.19. 113-23739069 BUILD#: SP1A.210812.016.G781BXXU4FVVC2 & ONEUI V 4.1) and I have a few known issues beside locus.

Let me know if I can support you with more information or testing!



Replies (4)


Hi again,

I think I found a solution:

During my tests last days I paired the manually sensors via BT system - this seems to be a problem I found out:

- I tried to check the SPD sensor in Garmin connect app today. Don't really use it often, because I track with locus and use strava as archive. Just use it for updates of sensor and X-Checks of recorderd tracking data.

Even in GC no connection was possible.

- tried to reset BT settings (cache and data of system app), didn't work.

- in the next step I reseted complete system network settings: after that I was able to connect sensor with GC and Locus with data displayed!

- problem is if I connect with GC, speed sensor (HRM and CAD not supported by GC) is paired automatically in BT system settings via pairing request and If this is the case it work only 1x. If connection is lost cause of inactivity or app restart, I have again connection issues (locus & GC) until I reset network settings again.

HRM and CAD still worked, think because they are not paired (like it wa the last days) in BT system app I think.

Conclusion: BT 4 LE sensors may never be paired in system app with android 12 (or Samsung s20 fe / one ui 4.1?). Otherwise no data connection is possible until system network settings reset?

I'm not that into android system and / or BT connection in generell. My conclusion is just an assumption, based on trial and error.

But make this any sense to you (as an experienced developer familiar with BT sensors and android?

I'll test next days, if this workaround is a permanent solution.




Hii Michael,

this is new info for me except for one important piece of info. In Bluetooth 3 system, the pairing was necessary. But with Bluetooth 4, do not pair devices at all! All is done over apps that deal with certain BT devices and yes, I remember in the early days of experiments with BT, that pairing BT4 devices caused troubles for me as well. So this matches to your own experience, right?

You anyway wrote that some Garmin app pair devices automatically? Hmm, then do not use it :).

With this news, give it please a try and test if the BT connection in the app is stable and working. I have positive tests and no problem so far. Sometimes, reconnecting takes a while (up to 30 seconds), but this does not seem to be a problem of the app. It seems to finally be fast and stable.

Jiří M. aka Menion


Hi Menion,

first of all sorry for my very late reply. First I forgot to update thread here and afterwards I wasn't able to ride for a longer period.

But I have good news:

After a testing with a few long rides in the last days it seems that sensor connectivity is working now like it should be. Before testing I resetted my connection settings (cache and data of system app), didn't pair the devices again and didn't connect speed sensor with Garmin connect app (HR & cadence are not supported in garmin app) this time.

In Locus I could pair the sensors (Garmin HR, speed & cadence) and got correct data displayed. The "no valid data" issue no longer occurs, too - fine!

Sometimes it takes litle time (up to a minute I think) to reconnect after a break, but reconect in generaly works.

Thanks for your assitance!



Hello Michael,

this is very good news! Re-connect may take a while, this is true. App tries to reconnect with a small delay (30 - 60sec) to prevent too often testing of connection.

If there will be any unexpected problem, feel free to write me anytime. Enjoy your rides!

Jiří M. aka Menion

Replies have been locked on this page!