This object is in archive! 

Line-of-route colour in guidance mode

Richard Philpott shared this question 22 months ago
Answered

Hi,

I'm using "Guidance" mode rather than "Navigation", and this meets my needs very well, However, I have one small irritation, On the maps I am using my preferred colour for the line of the route is blue, to contrast with the map - red and orange/brown are used for many roads, making it harder to distinguish a red line from these at a quick glance.

The line always appears in red, however (see screenshots). Is it possible to change this? I have changed the only settings that seem relevant, but still get a red line ...

Thanks,

Richard.

Replies (3)

photo
1

Hi Richard,

the original color of the route is blue and when you start guidance along with it, the route becomes red? That's sort of strange because the guidance mode doesn't change the color of the route... What version of Locus Map do you have? We aren't able to simulate this issue with the latest version.

photo
1

Hi, thanks for the reply.

Yes, that's exactly what I have been seeing, as shown in the screenshots. The default colour for the route's folder is blue, and it appears blue until I start guidance along it. I saw this again on the two routes I cycled yesterday.

However, I have just tried a couple of (very short) local walks to reproduce the behaviour, and could not - the line remained blue. As I almost always have track recording on when following a route I tried various combinations - guidance and no recording, turning on recording before guidance, and vice versa, but the line remained blue.

So I'm now puzzled, Maybe we should put the question on hold and I'll report again if/when I manage to reproduce it, and try to note anything different about the circumstances.

BTW, I'm running version 4.8.2 on Android 12 (though I was on Android 11 when I first saw the problem).

Thanks again,

Richard.

photo
1

Aah, got it!

If I plan a route in the app, it stays blue in guidance mode.

But if I import a route from a GPX it changes to red in guidance mode.

I've attached a couple of screenshots and the corresponding GPX, although it seems to happen with all GPX imports.

It's still weird, but at least it's now reproducible.

Richard.

photo
1

Hi Richard,

thanks for the pictures and the GPX. Unfortunately, the problem wasn't simulated and remains unknown. Could you please make a backup of your settings via the Backup manager and send the backup file here for testing?

photo
1

Hi Michal,

Settings attached as requested.

Richard.

photo
1

Hi Richard, I've got it too :) The guidance changes the line color to the default setting (Locus settings > points&tracks > track line style) - you have it red. So change the global color to the desired color. I have to find out why this happens - I'm not sure this is a wanted feature. Thanks for reporting it.

photo
1

Thank you! Because all my routes are in a folder with track colour set to blue, I hadn't noticed the global value was different. As you say, it seems unlikely anyone would want this behaviour (especially since it only seems to happen with imported GPX's), but I'm happy there's an easy workaround.

Richard.

photo
2

Hi Richard, the issue has been fixed, please check it out in the next app version. Thanks again. Michal

photo
1

That was quick! Thanks, I'll give it a try when the new version lands in the Play Store.

photo
1

I confirm it's fixed in 4.9.0 :-)

Replies have been locked on this page!