No Sharing or saving in Android 12

Daigers shared this problem 21 days ago
Not a Problem

Hello,


it's like so often. A new phone, a new Andriod version = new problems.


My new phone is a Samsung A52s 5G with Android 12. After installing Locus Map Classic (v. 3.60.0) and the Field Notes addon (v. 1.4.6.2), I noticed that it is no longer possible to share Field Notes (e.g. by mail) or save it offline.


4 years ago I had already opened a ticket with the same problem (Topic). At that time the problem could be solved by setting the "Storage" permission for the Field Note Addin. This worked until my previous phone (Note 8 with Android 9 in the end).


In Android 12 you can only set the permission "Files and Media" for the Field Notes addon. But even with this permission enabled, an error message always appears ("can't write to file!" or something like that). So no sharing or saving is possible.


Directly in Locus in the Geocaching Tools there is still the Logs Manager. If I go here on "export to file" and then on "share", it works.


So it seems very likely to be a permission problem in the Field Notes Addin, but this cannot be solved by activating the existing permission "Files and Media".


Because the Field Notes addin is a bit more comfortable, I would like to continue using this.


Greeting Daigers

Replies (1)

photo
1

Hello,

since Android 11 apps can't access folders of another apps due to security reasons.

So add-on really can't get into the Locus directory and therefore can't work properly.

To work as before, add-on needs "All file access" permission, but this permission is granted to only apps selected by Google.

I am sorry, but in this case I can't help you.

You can try to contact developer of this add-on. Maybe he can find another way how to update this add-on to work again.

Regards,


Zdenek, Locus team

Leave a Comment
 
Attach a file