"Can't write to a file!" again

Bohuslav Roztočil shared this problem 50 days ago
Not a Problem

Hi people,

for some time I cannot share fieldNotes.txt. At first it stooped work with OneDrive after about a year or more with Google Disk, too. So I fell back to using Store offline ("Offline úložiště" in Czech) and manually sharing it using Google Disk. Yesterday it stopped working, too.

I googled and find "solution" - https://help.locusmap.eu/topic/fieldnotes-chyba-zápisu-do-souboru. I've looked for 1.4.5.1 APK, installed it, but the problem haven't changed.

Today I started to investigate again. Application has been auto-updated over the night, but I don't think it worsened the problem.

I started ADB and looked at the logs. At first I started in the "Add timestamp to file name" mode, the checked the option off and tried again. I tried both operations, "Store offline" and "Share". Then I changed language in my phone from Czech to English (it solved problems I've got with Kindle for Android some time ago) and tried again.

Although both operations produced the same message on the phone screen, "Nastala chyba při zápisu do souboru!" resp. "Can't write to a file!", only "Store offline" produces corresponding loggings.

I'm attaching the logs (for Czech locales only) and screenshots.

  • Two of the screenshots might look identical, but one has been saved after touching "Offline úložiště" and the other after touching "Sdílet".
  • You can also see, that I looked for Field Notes application PID, I used it to filter only the related lines.
  • At the end you can find listing of the problematic folder.

If it were on regular Linux and I, as its owner, could impersonate as root, I would simply add u0_a486 user (the Locus FieldNotes owner) to sdcard_rw group or change folder's permissions to allow writes to anybody, and problem would be solved (I've actually tried the chmod, but nothing happened, not even an error has been printed).

The last information - I have Locus Map 3 Classic and also Locus Map 4 applications installed in "shared" configuration.

As the application owner is said to be unresponsive, I hope maybe someone of you could devise a way how to grant missing permission to the Locus FieldNotes add-on/application.

Replies (2)

photo
2

Hello,

unfortunately, this is an error with the add-on, so you have to contact its developer: locus.fieldnotes@gmail.com

Or you can try the built-in "Logs manager" in Locus.

Regards,


Zdenek, Locus team

photo
1

Thanks! Logs manager does everything I need! Guess I've never needed the Fields notes addon... :|

photo
1

Hello, I am glad it helps.

Have a nice day.


Zdenek, Locus team

photo
photo
1

Unfortunately, I have the same problem for some time. It probably also has something to do with the permission changes in Android. After updates to Loucs 4 and also with reinstalling the phone, I can only select the main Locus path in the Field Notes Addon, where the addon is apparently not allowed to save, but no other path is choosable. Isn't this also an issue with Loucs? I continue to use the addon because it also had more functions so far. But apparently, just like the geocaching functions in Locus, this addon is little or no longer maintained, which would be a pity. I have also written to the above contact and hope the addon can be used again soon. But may you from Locus can support also here?

Kind regards!

Jens

Leave a Comment
 
Attach a file