Route planner makes Locus Map Classic crash

Vital Frederic shared this problem 6 months ago
In Progress

Hi!

I've been using Locus Maps Pro (now Classic) for a while now and I've always loved it, except that I never could get the Route Planner to work properly. I tried both Graphhopper and BRouter in the past, neither would work so I just used the route planner with straight lines without it snapping to tracks/roads. Rather cumbersome, so I reïnstalled BRouter last month, downloaded the regions I needed and IT WORKED! I was happy as a kid, untill Locus started to crash on the feature. Now, when I use route planner, it can go both ways 50/50; sometimes it works perfectly and I can ride an hour following the route, the next route I try to plan Locus just keeps rendering ("busy" in the small black box) or it shuts the app all together.

Any idea what could be wrong?

I'm on a Ulefone Armor X5, Android 9.

Replies (7)

photo
1

Hello,

the unsnapped routes could be badly selected routing profile only. Did you choose the type of activity?

The second problem - is there any error code or any message displayed?

Thank you.


Zdenek, Locus team

photo
1

Hi!

Yes, I played around with different types of activity and vehicles but it didn't make any difference.

There is no error code, only one of two messages that are displayed randomly so it seems:

1. a black box in the upper center of the screen saying "busy" as if it's rendering the route. It stays on (1 hour or longer) untill I close the app. I can still use the app (following a gpx or just see my current position on the map) but certain functions don't work anymore (e.g. make changes to the auto-zoom).


2. the screen goes black, and after 20sec or so the menu "wait", "close the app" or "send feedback".

Thanks!

photo
1

Hello,

if the app crashes, please try to log this error to determine, where the problem is.

Please follow these steps and then send me the log which will be created.

Thank you.


Zdenek, Locus team

photo
1

Hi Zdenek,

It's been a while. In the meantime I've tried some "general stuff" like updating the BRouter regions, deleting BRouter alltogether, online vs offline attempts,... but nothing made the route planner work, if anything it made it worse; now failure to go into route planner mode is 100% of the time, making the app crash every time.

While trying to log this error seemed very cumbersome at first, following your steps, it wasn't really. I've sent the log zip file to the mail address mentioned on the how-to-create-debug-log page. Do you want me to send it to you through here as well?

Thank you for taking the time and effort to follow this up!

photo
1

Hello,

I am sorry, but there is nothing in the mail.

Please, can you try to send it again?

Thank you.


Zdenek, Locus team

photo
1

Hi Zdenek,

I sent it again just now, hope it gets through this time around. It's a zip file, just as I received it following your instructions page.


Thanks again!


photo
1

Hello, I am sorry, but still no email with attachment.

Please, try to upload that file to some cloud service and share link with me in the personal ticket. Thank you.


Zdenek, Locus team

photo
1

That's strange...

I just sent you a private ticket ;o)


photo
1

Hello, ticket arrived. Thank you.


Zdenek, Locus team

photo
photo
1

Hello,

please, can you send me some screenshots or better create a video documenting this issue,

If you don't know the right app, I would suggest AZ Screen Recorder for screen recording: https://play.google.com/store/apps/details?id=com.hecorat.screenrecorder.free

Does it happen only with BRouter, or with any other router? Can you try online LoRouter in Locus Map 4, please?


Zdenek, Locus team

photo
1

Hi Zdenek,


It happens with BRouter and LoRouter, both on and offline. Haven't tried another router, basically because I don't know any.

When you say you want me to try in Locus Map 4, that means I have to download LM4, but I'm afraid both versions will conflict with each other. I've read comments of people having trouble with their Locus Classic Pro after installing (and un-installing) the new version, and I, like them, am really fond of the Classic version that I'm so used to now. Have you heard this before?


I'll try the screen recorder and send you the result!


photo
1

If I remember correctly, there is no LoRouter on Pro.

photo
1

Hi Zdenek,


Did you receive the screen recorder video I sent you?


photo
photo
1

Hello,

I am sorry for the late reply.

As the planner freezes right after the start, it is possible that it tries to load some previous route that is broken/missing.

You can try to choose any (short) route from the Track manager and re-route it.

It should reset the planner into a working state.

Please, let me know if it helps.


Zdenek, Locus team

photo
1

Hi Zdenek,

Just found your reply, got to it immediately and now IT WORKS! Thank you very much for your support, I really appreciate it!

Any idea what I did wrong to cause the problem so I can avoid it in the future? What I never did was "Clear the route planner" before I went back to regular mode to follow my GPX. Maybe that was the culprit?


Anyhoooo, thanks again!!

photo
1

Hello,

I am glad it works again.

The planner usually opens in the state you last left it in.

Sometimes it happens, that (with long or complicated routes) it has problem to restore that last state and that was probably your situation.

Our developers take a look at it.

Regards,



Zdenek, Locus team

photo
Leave a Comment
 
Attach a file