Point attachment erased from device on Locus Classic 3.62

Alfonico shared this problem 3 months ago
Solved

Hello

Locus Map Classic 3.62 and 3.62.1 on Samsung Galaxy S5 Android 6.0.1.

After adding an attached file to a point using "Attachment" "Select other file", the file is deleted from the phone as soon as I click on the attachment if I go back to view the point details. The name of the file is still visible in the "Attachment" tab, but clicking on it does nothing and the file has vanished from the phone storage.

I have tried text files and GPX files.

I have tried files located in the external SD and in the internal storage.

I have tried to uninstall Locus and install it again from Google Play.

I have uninstalled version 3.62.1 and installed version 3.61 from the Locus archive site.

The problem disappears, all is fine as before, attachments are opened as many times as needed and don't vanish.

The problem seems therefore related to version 3.62 and 3.62.1.

Regards

Replies (4)

photo
1

Hello,

I am sorry, I can't simulate this issue.

Can you describe your exact procedure, step by step, to me?


Zdenek, Locus team

photo
1

Hello.

Many thanks for your fast reply.

The problem concerns the points that are part of the Locus points database "waypoints.db".

Description of what happens on both version 3.61 (the one that is OK) and version 3.62:

- Open the point details either by clicking on it on the map if it is visible and then clicking on "details", or by selecting it in the "point manager". This will open the point detail screen with 2 tabs, "BASIC INFO" and "ATTACHMENT.

- On the "ATTACHMENT" tab, add an attached file by clicking on the + located on the upper right corner of the screen and then "Select other file". This opens a browser when I can select a file anywhere in my internal or external phone storages. Once selected, the name of the file appears in the "ATTACHMENT" tab.

- Go back to the map screen.

- Open again the point details: in the tab "ATTACHMENT" the name of the file appears.

What happens on version 3.61:

- Clicking on the file name opens a window asking which application is to be used to open the file. In the case of a GPX file, selecting Locus will open a window with some options to display or save the track. In the case of a text file, or an image file, or a movie, the file is displayed in the selected application. This is the desired behaviour, that has been the normal behaviour on all Locus versions up to 3.61.

What happens in version 3.62 (and 3.62.1):

- Clicking on the file name does either nothing (GPX file), or opens a window asking which application is to be used to open the file (other file types). Selecting the desired application to open the file does either nothing, or opens a blank file. When looking for the file (GPX or other type) in an Android file browser, the file has vanished completely, irretrievable, which is a big problem as the file could have been unique and important. The name of the file is still visible in the "ATTACHMENT "tab.


Let me know if you need more info.

Regards.

photo
1

Hello,

we made some improvements and it should work properly in the next version.

So please, let me know after the update.

Have a nice day.


Zdenek, Locus team

photo
1

Thanks for the update. I will check when the new version is available. Regards.

Leave a Comment
 
Attach a file