File manager does not show GPX files

Ulli shared this problem 4 months ago
Solved

recently I switched to an Android 12 device.
The automatic smart switch functionality installed Locus Maps Classic
3.63.0 on the new one.
On my old device I had Android 8 and Locus Map Pro 3.57.1

But now I'm not able to import gpx files (and others) anymore:
the filemanager doesn't show any other files than jpg and similar
ones.
I think this is a problem with changed permission managment in
Android 12 (or whenever it was changed between Android 9 and 12)
Locus Maps Classic has only the permission
"Allow access to media only"
However, I think it would need
"Allow managment of all files"
But there is no such option for Locus Maps Classic.

Replies (5)

photo
1

Hello,

unfortunately, the "all file access" permission is only for file managers and it is granted by Google itself. Locus can't have it.

Anyway, Locus uses your Android built-in file manager, so you should see everything like when you browse the files on the phone.

Can you please describe your exact procedure to me?

Regards,


Zdenek, Locus team

photo
1

Hello Zdenek,

this morning I sent you an answer upon your email to Locus Map <locus.map@asamm.com>

But I got a delievry failure.

photo
1

I put a gpx file into the directory /UH/Test" in the main storage.
Then I moved the file manager of Locus map to this directory, but
simply can't see this file
See screenshots
1_Open File manager _Locus Map Classic.jpg
2_Move to directory_Locus Map Classi2_c.jpg
But the file is there:
3_directory contains gpx_File Manager +.jpg

Anyway, I found two workarounds:
1. select the gpx file with file manager and choose
"Open with => Locus Map Classic
then waypoints are imported into Locus Map
Is this, what you described with "Anyway, Locus uses your Android
built-in file manager"?
or
2. Place the gpx file into the Locus folder of the main storage
Then the file manager of Locus Map does see it, and can import it


So, as long as one of these workarounds is still working, it's fine
with me.

photo
1

Hello,

please, use the "Device Storage" option instead of "Main directory" when you browse for the file.

It should work.


Zdenek, Locus team

photo
1

Yes, this works as well. So, it's a third possibility. Thanks!

Leave a Comment
 
Attach a file