Track recording broken

Torsten shared this problem 19 days ago
Not a Problem

I have been using Locus for years (Classic Paid), but am suddenly no longer able to record any tracks.

When turning track recording on as usual (manual start, no countdown, no ANT devices, no audio trainer) it seems to work at first, but it doesn't record any points. Even when walking for hours. The notification message is stuck at (0 h : 00 min : 00 sec | 0 m | 0 points).

I also tried different profiles (walk, bike, car), none of them work. GPS fix is there and GPS is kept alive.

The power/GPS management settings are as recommended (GPS always allowed, autostart enabled, battery saver: no restrictions, lock in RAM enabled).

I can't tell if a recent update of Locus triggered this behavior. My last successful track recording was on October 3rd and I didn't try to record since then. Everything else in the app works normal, the database is writable as I can create and save new routes/waypoints.

Other apps like Outdooractive can record tracks on the same device.

Version: 3.63.1

Device: Xiaomi 11T, MIUI 13.0.7.0, Android 12 SP1A.210812.016

Replies (5)

photo
1

Hi,


I've tested Locus Classic on a Xiaomi with Android 12 and MIUI 13 and track recording works OK. Have you tried reinstall or just phone restart?

photo
1

Hi,

thanks for trying :) Phone restart didn't change the situation.
I don't really want to lose my database, so I didn't try reinstalling yet. Thought maybe there's a known bug or something.

Is there anything I can provide to debug? Logfiles, etc.?

photo
1

Please try this first : Go to settings > default directories > uload app data > this way you can save all your app data for future use. Then reinstall the app > go to settings > default directories > load app data > restart

photo
1

Sorry for the late answer. I have been quite busy in the last few days.

What I found out so far: When I delete all of Locus' data from the Android system menu, the app starts like after a fresh install and track recording works.

Then by using settings > default directories > load app data from my backup location I can restore the database including tracks, maps, etc.
Track recording still works at this point.

Then for restoring the settings and UI I do backup manager > restore and restore the latest autosave in the database location. As soon as I include "settings (Einstellungen)" in the contents of the recovery process, track recording stops working. The same thing happens if I restore an older autosave.

So it must be something that is included in the settings.
Is there a way to debug what's happening?

photo
1

I found the problem.

I had "Google Services assisted location" in GPS settings turned off. After turning it on, track recording works again.


It's not a setting I changed recently. In fact, I think I had it that way in Locus for years. But what I recently changed is turning the network location services off in the phone's system settings as it massively drained my battery.

Does that make any sense? Can anyone else try whether turning off that option causes track recording to not work anymore?

photo
1

Hi Torsten, unfortunately, the Xiaomi platform has many such "specialties" that don't occur on other phones. I personally have a Note 10 Pro running MIUI 13 but I can't find the option to turn the network location services off - where did you find it?

photo
1

It's in Settings > Location > Location Services > Google Location Accuracy > turn "Improve Location Accuracy" off

photo
photo
1

You can back up the database with Backup in Locus. Preferably to a cloud. First look in the help
https://docs.locusmap.app/doku.php?id=manual:user_guide:tools:backup

photo
1

Experiencing the same issue, on a OnePlus Nord 2 and Nord 2T. Both are on Android 12, before upgrading Android on the Nord 2 everything was working fine. Tested both version 3.63.1 and latest 4.x

Tried reinstalling the app but still the same issue.

I'd be happy to try other debugging steps if needed

photo
1

Hi,

I've tested the app with both the Google assistance OFF and location accuracy reduced only on GPS (network location OFF) and it does record the track. Check your track recording profile settings > GPS accuracy parameter if there is a reasonable value. Without the assistance features, the GPS accuracy may be limited and out of the selected range which results in zero recorded track points.

photo
1

Hi Michal,

I have tested every combination today. Track recording only works if I set "Google Services assisted location" in Locus' GPS settings to on.

Changes to the Google Location Accuracy system setting don't matter and the GPS accuracy parameter in the track recording profile is set to the default value of 100 m, which is quite reasonable.

So I guess it didn't have anything to do with the Google Location Accuracy system setting after all. Maybe a system update by Xiaomi changed the behavior. As you said Xiaomi often has "specialties"...

Leave a Comment
 
Attach a file