This object is in archive! 

Export fails

Szilárd Farkas shared this problem 13 months ago

I try to export any of my logs to no matter what format, the process looks like it happens successfully. I even get the green "Process successful" message, but the folder is empty. When I select the "Share exported data" I never get the share popup. Tried a bunch of folders on the phone and also on the SD card.

I'm guessing it's a folder permission issue.

I was thinking to reinstall the app, but don't want to loose my tracklogs.

I used export many times before without issues. What might be the problem?

Locus 4.15.2

Android 13 (Samsung Galaxy S20FE)

Replies (5)


Your tracks are not only in an export folder, but first of all stored in a database.

Make sure you use the Locus feature to "park" all data for future re-install. And I would do a backup to an external device in addition, just to be safe (latter is advisable regardless, BTW.)



sorry for the delay but our colleague who's responsible for this topic hasn't been in the office for some time and I'm taking this over from him.

- is the issue still present?

- if yes, what path did you set for the export?

- what storage do you use for the app's main directory (see in the "about app" section - send a screenshot if you are unsure)


Yes, it's still present.

No matter which direcotry. /sdcard/Locus is the default, but I tried to create other directories and it always fails

Main directory is /sdcard/Locus


Please do the following:

- open Settings - Backup & Filesystem - File system manager - Set the main directory - 3 dot menu by the "Private folder in internal storage" - tap "Select"

- then go to Settings - Backup & Filesystem - App data transfer - Load app data > continue. It is necessary to select the original "sdcard/Locus" directory for data move.

- restart the app


Thanks, that worked!

Replies have been locked on this page!