Attachments are not shown since the latest update

Dirk Laukamp shared this problem 2 months ago
Not a Problem

My Pictures in the pois are No longer visible, although i have Not changed folder/ have Not deleted

Replies (17)

photo
1

Hi Dirk,

were the pictures made with Locus Map or did you take them with your default camera app and then attach them to the points?

photo
1

Hello, I took them with my camera App and attached them. And it worked since the last update of locus.

I tryed to shoot Photos out of the locus app with the same result. Not visible

photo
photo
2

Hi,

could you please open the point detail > click on the photo > tap the info icon > display the path to the photo:

667c3a389d01b17a9c2a1f0906450d5a 86ac9ab087b4e551d61be0b86999c5fc

thanks

photo
1

sorry, one correction: It works, when I take the photo out of the locus app

photo
photo
1

Dirk, did you recently update the operating system on your phone? Which version of Android OS do you use?

photo
1

Hi Michal,

I have Android 13, safetypatch 090523

photo
1

Thanks, now please, we need a bit of testing to find out the exact cause of the problem:

- please install this version of Locus Map: https://gofile.me/7ecf2/ix8iXodZX (don't worry, you won't lose your data)

- long-press the main menu button > Setup logging > check "Log to file"

- open a few points with the missing photos and close the app

- go to the /Locus/logs, copy the newest file and send it here for analysis

Thanks!

photo
1

Hi Michal,

so I first have to uninstall my current Version?


...and where do I have to press the main menu Button?


Thanks for help!

photo
1

No, just install the beta version over your current one. Press the main menu button here:

ce6fb50131549874a37a167213365ab0

photo
1

Hi,

here is the logfile

photo
1

Thanks, and now please send a screenshot of Locus Map's permission settings:

21586bf63933a1294870d92704bad2f3

photo
1

OK, here it is. Photos and videos are allowed.

I have just checked it in the App, now it works!!

Only the preview of some Pictures is not shown...see in the attachment


Mmh, i have not changed any settings, it is a little funny.

photo
1

Thanks a lot, this really helps in the issue identification. However, could you please repeat the action once again and make another log? We may have found out something but we need to verify it.

photo
1

OK, here is the latest log

photo
1

Hi, thanks a lot. The only problem is with following pictures:

/storage/emulated/0/Download/DS1.jpg

/storage/emulated/0/Download/DS2.jpg

/storage/emulated/0/Download/DS3.jpg

/storage/emulated/0/Download/DS4.jpg

Are they really physically stored in the folder yet?

photo
1

Hi Michal,

I cannot find this pictures on my phone.

This 4 pictures are the pictures without preview? But they are named different.

photo
1

Hi Dirk,

yes, these four are without preview because the app can't find them on the phone. Why they are renamed, we don't know. Locus Map does not rename attachments, it's only up to the user.

photo
1

Hi Michal,

You are right, the preview problem ist a user problem­čśü. So I am glad, you helped me with my main topic.

Thanks a lot!


Greetings Dirk

Leave a Comment
 
Attach a file