Install older App versions of Locus

Sonny shared this question 2 months ago
Answered

For testing reasons I wanted to install an older App version of Locus (currently I've installed latest Locus version). So I followed manual https://docs.locusmap.app/doku.php?id=manual:faq:devices_older_android and downloaded an older version from here: https://drive.google.com/drive/folders/1U8U1D-NGQ9CAnqXAkleEXi46wH2T7tMR

The problem: If trying to install it on my Android 13 phone it's being refused with the message: "App not installed as package appears to be invalid".

What's the problem here, and whats the best method to quickly install an older Locus version if already have installed an actual version, and keep its settings, tracks, maps and elevation-files?

Replies (5)

photo
1

Hi Sonny,

which APK is affected?

photo
1

I've got LM v4.19 installed and want to dwongrade to LM v4.18

photo
1

It is necessary to uninstall the newer version before the downgrade. I've just tested both 4.18 versions (AFA and non-AFA) and there was no problem with installation.

photo
1

I see, but in this case I've to take care of saving track, settings - as well of map and elevation data? And after installation of older Locus version, I've to import all this features again, right?

photo
1

Usually, the OS asks if you want to preserve the app data but it is recommended to make a backup before uninstall.

Leave a Comment
 
Attach a file