Auto sync not working and high battery usage

Wiebe shared this problem 11 days ago
In Progress

Hi, i took a pro subscription for the auto sync so i could sync a travel plan from my phone to my car android unit. Both android 10 (lineage on phone).

The manual sync works on both devices and i see the change on the Web. But the auto sync doesn't work. To test i changed points on my phone as on the Web. No auto sync.

I reinstalled locus and did a force stop. I noticed a high battery consumption by locus even in flight mode during the night.

Another indication is that i can add or change points on the Web, but can't delete then. Point is not found, but i can change the name.

Hope you can help


While looking for the log, i now get a message that sync is paused although auto sync is on

Replies (9)

photo
1

Hi,

you probably do not have Google Play Services on your phone which are necessary for the detection of a data change on the web side. Therefore, if you change anything on the web library, the change must be synced manually. The reversed sync (app => web) should work automatically.

As for the battery drain - that is unfortunately very difficult to simulate and without simulation we can't detect / investigate and fix a problem.

photo
1

Hi,

I do have Google play services installed and installed locus through Google play.

Both ways are not working.

The battery drain started when i activated auto sync. It's probably keeps trying to sync, but doesn't. So probably the same problem.


How to resolve?


Ps i have android 12

photo
1

For me the battery drain is the same, but it is synchronizing all the time. After finish of one, the next run starts in a few minutes - without any activity on the phone nor tracking nor anything else.

I've created a Locus log file some time ago - need to find it and attach.

photo
1

Hi

thanks for the additional info. To investigate the cause of this issue, please, follow this:

  • Download the latest beta version from http://bit.ly/lmVersionsTest
  • After installation, run the app and long-press the main menu button ( 65ab74f02671fb4a2ceb0db7c0510f6e )
  • Choose the "Log to file" and make sure all categories in it are turned on
  • Then close the app, wait for 10s, and run it again.
  • Try to replicate all your issues (it will be logged this way)
  • After that, send me the logs which will be created in "Android/data/menion.android.locus.pro/files/Locus/logs"

Thank you very much.

If something isn't clear, feel free to ask me.

photo
1

Hi,

Thanks for going forward. Attached the requested log file. I used the normal beta (not afa) apk. Still no sync both ways.


Kind regards

photo
1

Hi Michal,

https://my.hidrive.com/lnk/FaD3J0uue is a link to a ZIPped text file that contains 250 MB of log data, from a single day, without any tracking or new points or so.

For the 5 hours between 11 and 16 hours Locus produces 2,122,554, running a useless sync every 10 minutes. There was no tracking active, nor any new points. And the device this Locus instance is running on is the "master" of the sync.

This is eating battery like crazy, forces frequent recharges and hence reduces the lifetime of the device!

An interesting case for Menion, I presume ...

TXs and cheers

Michael

photo
1

Even when auto sync is turned off in app, i still have a higher battery drain than normal. Even in flight mode. Hope this gives a further clue. I uninstalled the app for now, but saved the app data.

photo
1

Hi guys,

@Wiebe, I've analyzed your log and there is nothing unusual. Most of the log is because of enabled "Location" logging, so a lot of GPS info. Next to it, one sync where two points were correctly sent to the web planner (server). Not sure if this sync was automatic or manual. Anyway we may check this later (with some special version). More critical is battery consumption. How do you measure app consumption, so how are you sure, that it is a Locus Map problem?

@Michael Bechtold, here it was even more interesting. Seems, you have 22 tracks in your database, that have defined speed values equal almost to the light! The app has a problem with it and refuses to sync them. Unfortunately, app receives info from the server and tries it again and again ... I've just published a new Beta, where this should be fixed, so please give it a try.

Btw. two questions: do you know which tracks may have such values and how they get into the app? And the second ... were you doing some migration of the app directory between devices or anything that may affect app /data/config/.config.dat file?

photo
1

Hi Menion,

The battery usage was provided by Android that locus was using significantly most of the battery. Then i went testing it myself. Battery usage seemed to drop a little when i turned off auto sync in the app but still significant. Next test is to delete locus 4 completely. Battery usage normal as in, no battery drain in the morning when go to bed with full battery and in flight mode.


As for the 2 syncs you saw. I managed to have 2 auto syncs. One after reinstall and one after a forced stop. But both didn't work a second time. Maybe that's the syncs you saw?


With regard to the gpx tracks. The ones in gpx tracks are imported ones so i dont know if any editing is done. The only recent editing within locus 4 has been deleting end of a track (maybe two) as i forget to turn off recording and drove home (no speed ticket :)).

And of course the migration of locus classic to 4. I now use classic again. I have one week left of free trial for pro. Hope this can be extended until resolved.

Have a nice weekend

photo
photo
1

TXs a lot, Menion, for the quick response and the new beta!

I've installed it a minute ago.

Track with near speed of light? That's how I go on the highway ;.)))

Seriously: the only mechanics that may have created those tracks is track edits.

When tracking and staying in one place, regardless of filters and settings the track recoding goes crazy around the real location. Sometimes many artificial km. And sometimes I fix such by deleting the rogue sections of the track.

There are other situations where I forgot to activate Locus tracking when leaving and fix that manually, too. By inserting pooints on the way as needed. That may cause anomalies, too. I do NOT do edits of gpx files and then import.

I am using the AFA version to keep using my <Android INT-SD root>/Locus/... data and I fdo not recall a re-install in the recent past on this device. But I also cannot 100% deny. What I DO know, though, is a re-ionstall on my Tab S6 lite.

Triggered by a problem in the help desk I did experiments with /Android/media which finally forced me into a de-/re-install. Also <INT-SD>/Locus ... HOWEVER, that (AfA) install used the worst location: private folder under /Android/data. So I did a migration to /Locus. That migration copied a 56kb tracks.db over my 1.1 GB real life tracks.db. Not good. OK, sync worked and the result was a 990MB tracks.db ...

Another observation from this most recent beta: in the database folder there are two 1.1 GB files now: tracks.db PLUS sync.db.

I trust you know how to get that under control!

But not before the weekend. Have a nice one.

Cheers

Michael

Leave a Comment
 
Attach a file