Locus- Authorization problem with geocaching.com

Patrik Sistik shared this problem 45 days ago
Solved

After recent geocaching API update I am unable to Authorize Geocaching features via Locus Map app. I am permanently getting Error 500. I have tried to get in touch with geocaching HQ (as per mail screen below), which does recognize this issue with some of the users. They are actually pointing to the 3rd party app providers to do updates connected with their API update, to solve our issue.


Is this something that can be fixed on Locus app end?

Phone: Xiaomi 11 lite 5g ne

App: Locus Map Classic

Replies (7)

photo
1

Hi Patrik,

we are sorry for the inconvenience. The new geocaching API has been implemented in Locus Map 4 but not yet to Locus Map Classic. It is planned for the near future. Thanks for understanding.

photo
1

Hi,

Please, take care on this for the classis users. We are locked out with two devices now and ae not able to play anymore. No download of pocket queries and no access via geocaching4locus add on (live map, cache update, logs download, etc).

Fixing this in Locus would be highly appreciated, and maintaining the addon would be gold! ūüėČ

Thanks!

Cheers, bigchen.

photo
1

There is still the possibility to manual import pocket queries by gpx (download on GC website or get it via email for <500 results). I know, not the best solution, but maybe a way to still be able to go geocaching.

photo
photo
1

Hi all,

- download and install the latest version of Locus Map from https://bit.ly/lmVersions

- download and install the latest version of G4L addon from Google Play

All should run OK after this.

photo
1

Hello,

unfortunately, not everything still works:
The authorization problems via API still exist

G4L live map OK

LOCUS V3.70.8

LOCUS cache hints/update caches NOK ERROR

LOCUS "GC Offlinizer" , images via API NOK ERROR

LOCUS "GCTools" NOK ERROR

LOCOS "Fieldnotes" NOK ERROR

ERROR:
This oauth-geocaching.locusmap.eu page was not foundNo website was found for the following web address:
https://oauth-geocaching.locusmap.eu/?state=locus&error=invalid_request&error_description=Code+challenge+required+to+enforce+PKCE+validation..

photo
1

Je ne parviens toujours pas à autoriser les fonctionnalités de géocaching via l'application Locus Map classic. Je reçois en permanence l'erreur 500. À quand les mises à jour liées à la mise à jour de l'API, afin de résoudre notre problème.

Merci

photo
1

Please download and install version 3.70.9. of Locus Map from https://bit.ly/lmVersions - Google Play verification has still been pending.

As for the "update cache" on LM Classic - this is processed via the G4L addon on which we have no influence - it is developed by a different developer. The same for other Fieldnotes add-on - it is not our product.

photo
1

Thanks to the developers for the quick adjustment!!

My status
LOCUS V3.70.9

G4L live map OK
LOCUS "GC Offlinizer" OK
LOCUS "GCTools" OK
LOCOS "Fieldnotes" OK

Updating the caches via LOCUS menu NOK
Download logs via LOCUS menu NOK

photo
1

"Updating the caches via LOCUS menu NOKDownload logs via LOCUS menu NOK"

- these features are operated by the Geocaching4Locus, not by Locus Map Classic. Please contact G4L support for help.

photo
Leave a Comment
 
Attach a file