IllegalArgumentException: Only chars are supported
Not a Problem
Hi,
I am using Locus Map Classic. Since yesterday I have a problem when downloading or updating geocaches. Often (not always) I get an IllegalArgumentException because only chars are supported (see attached picture). I would assume that this has to do with special characters (like emojis) in the cache title.
My impression is that this is mainly a problem on Groundspeak API side. Probably I will just have to wait a few days and they have fixed it. However, I could not find any information anywhere. So I thought I bring this to your attention.
Repro steps:
set marker somewhere
choose download geocaches in your area
if you do not get the error try it somewhere else
Best regards,
Thomas.
Files:
signal-2026-09-...
The same problem
Hi Thomas,
searching and downloading geocaches to Locus Classic is only possible with the Geocaching4Locus add-on. This add-on is not our product; it was created by a different developer, and it hasn't been updated for over two years. This is probably the reason why this doesn't work.
Hi Thomas,
searching and downloading geocaches to Locus Classic is only possible with the Geocaching4Locus add-on. This add-on is not our product; it was created by a different developer, and it hasn't been updated for over two years. This is probably the reason why this doesn't work.
You can do this internally in LM4. So it's best to use LM4.
You can do this internally in LM4. So it's best to use LM4.
Thanks for the info! Then it is probably about time to upgrade to Locus 4.
Thanks for the info! Then it is probably about time to upgrade to Locus 4.
Replies have been locked on this page!