addprovider(...), duplicite provider

Stephan Knull shared this problem 4 months ago
Not a Problem

Since today I see lot of above mentioned error messages in an orange box while locus is starting up. I have this on two devices (Samsung S5 Mini, Samsung 10 inch tablet). Is there something wrong with my settings and hiw can this be fixed - will a fresh install help?

Comments (5)

photo
1

Hi,

I guess that you customized the list of online maps via 'custom providers' config XML - https://docs.locusmap.eu/doku.php?id=manual:advanced:customization:online_maps

It seems that there are two records for custom maps that use the same provider id. Please check it

Thank you

Petr

photo
1

Hi Petr,

thanks for the quick reply. I did not bother intentionally with that file but now that you mention it I remember that I have applied some hack to add additional map providers not in the official list many years ago. Is it possible somehow to reset that one to defaults? Would it be of help to save all settings, uninstall, install, restore settings to restore the providers to default now?

photo
1

Okayfter reading through the docs provided in your link I just removed the custom folder and the isuue is solved.


Thanks,

Stephan

photo
1

Hi,

there was some 3th party plugins that could influence this settings file if you don't modified manually. However I'm glad that's fixed.

Thank you

Petr

photo
2

Hi Petr,


I can confurm now from my other device which had the same issue the pribkem is solved by deleting the custom folder.

One should never install hacky things ;)


Thanks and regards,

Stephan