Archived status not filtered in Found caches

Mojmir Volf shared this problem 4 years ago
Solved

When I filter Found geocaches in my database and want to further filter Archived ones, the filter will return zero results.

Comments (5)

photo
1

Good day Mojmir,


question is if problem is in Locus filtering or in missing information in stored cache.


May you write me GC code of cache, you loaded into Locus (by Geocaching4Locus add-on?) and that's not correctly filtered? Thanks

photo
1

e. g. GC2YQYG, GC2YWA6

I store found cache waypoints in separate folder. When I apply filter with positive "archived", I get empty result.

It seems to me, that "found" attribute somehow overrides not only "archived" but also "disabled" and "corrected" atributes.

photo
1

Hello Mojmir,


it took me a while till I found a time on this, sorry. Problem you found is in Locus since begin ... it is based on fact, that state of cache, like Found, Archived, Disabled etc. is very simply stored in icon. So icon define state of loaded point in list of points.


Unfortunately this is really bad system I wrote a few years ago. I've just improved code so this should be now handled correctly. Anyway all caches will need refresh, so some kind of update in database like re-import of PQ file, update over Geocaching4Locus or something like this.


Thanks for a report, hope it will work fine now.

photo
1

Hello Menion,

tahnks for quick response and fix. Is the POI database update enough to make it work, or I will have to update Locus application too?

photo
1

You of course have to wait on new version of Locus and then, in this new version, it is needed to update a caches to make it work correctly.