Audio couch reports unreliable

Vlad Kuzba shared this problem 2 years ago
Solved

With the addition of audio couch feature I started using Locus Map Pro as my training app instead of Endomondo Pro. But the LM audio couch feature is very unreliable in my case. I set it to report every 1000 metres but it never does. First I thought the sound level was too low for me to hear it. So I fastened my phone on my bike's handlebar to find out that the first report came after I'd rode 16 kms! Since then it reported the following 4 kms and then went silent again. The ride was 25 kms long. Any idea how to solve this?


My phone is a Xiaomi MI3 running Android 6.0.1 (CyanogenMod), Locus is up to date. Endomondo's audio couch works flawlessly.

Comments (8)

photo
1

Good day Vlad,

this is really interesting. I have never noticed such serious problems with Audio coach in Locus Map.

What about your track recording? Is final recorded track perfect without any gaps/straight lines? I'm asking because only what I have in mind is some aggressive battery optimization in your device.

In CM6 seems to be option in device settings > Battery > toolbar > Battery optimisation > and here is needed to exclude Locus Map app. May you try it if it helps? Or you may try to keep screen on for some time if it helps as well ( just for test case ). Thank you and sorry for a complications.

photo
1

Hi, Menion,


track recording is perfect. Locus is set to "Non optimised". See screenshot. To be honest, it has been behaving this way since I used the audio couch for the first time. When doing my workouts I usually follow the same route, so I know where the 1 km report should be played. I take my phone out of the pocket just before reaching the area and wait for it to speak. It keeps silent, even if the volume is set to max. Attached are also the two profiles I use for audio couch.

photo
1

Good day Vlad,

thank you for additional information. Really interesting.

Anyway we have just published new version 3.23.1 on Google Play also with a few changes in "Audio coach". So please test this version.

If problem remains ( and I expect it will ), would it be possible that I create for you special test version that will print out into file some additional information? Let me know after test, thank you!

photo
1

Sure, no problem with the test version.

photo
1

Fine. Because of one more issue I had to solve, I've prepared test version that print our some information what happen in Audio coach in your device.


Please download and install it, setup all that is need and try to use it. When you will be sure, there should already be some audio notification, close it and in Locus/logs directory should be a text file, log. So please attach it here. Hope there will be something useful. Thank you.

photo
1

Well, some more news about my issue. Latest version (not the test one).

Friday, morning walk, 1 hour, 5 km, AC works from start to the end. Profile "walking".

Saturday, morning run, 13 minutes, 1,6 km, AC works, profile "walking".

Saturday, afternoon ride, 1 hour, 17 km, AC doesn't work, profile "biking".

Sunday, afternoon walk, 1 hour, 6 km, AC works perfectly, profile "walking".


In all cases the track recording is perfect.


Will do some more testing, will keep you informed.

photo
1

Well, it seems, that the last update fixed my issues with the audio coach. Please close this ticket.

photo
1

Good day Vlad,

I'm really glad to read it. Thank you for confirmation that issue is already solved.