Auto backup does not work

Thomas K. shared this problem 5 years ago
Solved

Manual backup work. First (manual triggered) auto backup does work too, but schedules auto backup does not work. I have tries several times with different settings.


Please fix, though it is very import to me!


Thank you very much!


Thomas

Comments (16)

photo
1

Hello Thomas


this is maybe one of most important features at all due to possible problems on SD cards. I'm aware of this issue and will try to finally fix it to next version

photo
1

After the last update, it works well for me. Thank you!

photo
1

Perfect, for me too on two devices even after restart. You're welcome.

photo
1

Automatic backup stop working since last update, two days ago. :(

photo
1

Thanks Thomas,


one user on forum (tramp) found a problem. It's "canceled" by update of app. So just set it again and it will work till next update (and then probably also because I will fix it :) )

photo
1

That's it. Thank you!

photo
2

Menion, do you see a possibility to keep autobackup working after update? I'm so damn sure I'll forget to set it again after every second update...

photo
1

from what I read, there should be absolutely no reason why autobackup stops working after update. But I'm sure I'll find any way :)

photo
1

After the last update I get auto backup working by setting it again. That works fine for some days.


But one week ago it stops working for me at all. Setting it again, does not work. I do not install any device- or android-update or changed any (relevant) locus settings.


The Manual backup still works.

photo
1

Auto backup is not functional after update to v3.0.2, even after setting it manually (first disable, then enable again). What do you do to make it work?

photo
1

Auto-backup is quite funny feature for me. It's one of

  • most important
  • most simple
  • most problematic

I did again a few small changes (right now) so we will see if it helps in next test/public version. Sorry for a troubles guys. I'm sure that one day it will work as expected!

photo
1

Thank you for another fix, Menion! :-) And BTW, auto backup worked as expected for around one year in 2.x version, so it is possible ;-)

photo
1

Menion wrote:

I did again a few small changes (right now) so we will see if it helps in next test/public version.

It does not work in v3.1.3 here on Android 4.0.4. For the test, I de-activated auto-backup, then changed all settings (time, repetition, backups to keep) and after defined time passed by, no notification occurred and no backup was created, neither when Locus was still running nor when it was terminated, but time for next auto backup as set 4 days into future - that part works ;-)

photo
1

FYI: Also v3.2.3 does not do the auto-backup.

photo
1

Hi Georg and others,


I know I know :). Auto-backup is my small nightmare for quite a long time. And even I did a few improvements, I`m still not able to find out, why this function do not work as expected. So please, just keep in mind, that I know about it.

photo
1

Hi Menion,


I'm also observing very long pauses between auto-backups, e.g. for months nothing happens, than all of a sudden, the next ZIP files gets created. There seems no logic behind this. (Observing the version just prior to the current 3.25 one on Android 6.0.1)