Automatic screen works normally when switch Off, but do not turn screen On. (on Samsung Edge 9)

Przemek Nieprzecki shared this question 50 days ago
Answered

Comments (17)

photo
1

Hi Przemek,

could you please add some more information about your query? Best if you described the action step by step.

best regards

Michal, Locus team

photo
1

So, before i was using Sony Xperia XZ1 and everyday used opportunity to automatic lock/unlock the screen when navigate in the bicycle. Now moved to Galaxy Note 9, with latest Android and set this Locus function exactly the same way as it was on Sony. When I hear the message, screen do not turn on automatically like it was on Sony. Then i turn on the screen by myself it switch off normally after time which i set in the parameters. I also exported all settings from Sony, to Samsung suspecting that maybe i missed to set some small checkpoint, but it did not solve the problem.

photo
1

Hi Przemek,

for this feature, Locus Map needs to have system administration permission in your phone - does it have such? Then it needs auto-start permission and to be excluded from all means of system battery optimization (see https://dontkillmyapp.com/samsung)

best regards

Michal, Locus team

photo
1

thank you Michał, will check that and let you know if now work OK or not

photo
1

one more - how can i set system administration permissions to Locus? when i go to apps>Locus Map> i see only things like : Network, battery, deafoult memory, notifications, set as deafoult, permissions (there i have only localization, mic, memory)

if i go by 3 dots to see more permissions there os nothing like "administration permissions"

photo
1

I got that, it is ON with permission to on off screen

photo
1

Hi Przemek,

so Locus Map has all necessary permissions and still, it doesn't switch the display on? Or will you test it yet?

Michal

photo
1

i will test, will let you know the result soon

photo
1

If it's like for the Samsung S7, you have to do: apps> Locus Map> battery> optimize usage> then uncheck 'locus map'.

photo
1

i made all you've suggested, but unfortunately it did not solve the problem...

photo
1

Have you try “Settings / Battery / Unattended Applications / Unattended Applications” and add locus ?.

Have you checked that the 'energy saving' mode is deactivated ?.

photo
1

Unattended Applications - do not see any possibility to add there any app

I set the phone to max performance (which i believe is energy saving mode OFF) - no result. maybe you can find someone with Note 9 and check that?

by the way - i checked on Samsung Galaxy TAB2 - all works OK with no special settings.

photo
1

Hi Przemek,

if you applied ALL methods recommended in this article: https://dontkillmyapp.com/samsung, if Locus has all system administration permissions and all properly set in its own settings, and if the problem persists, I'm sorry. I have no more advice. Try Locus forum and other users if they have some hints: forum.locusmap.eu. This is something above our own posibilities.

best regards

Michal, Locus team

photo
1

Understood, thanks anyway. I will keep trying. If I find a solution will post there a hint.

photo
1

Hello Michal,


i think that i found solution to my problem, want to share if anyone have the same. Today i was playing with settings for notifications. Locus notifications were originally set to "disabled". I did not think that it can influence on automatic screen ON/OFF , but to check I activated all notifications , and guess what - auto screen on/off seems to work.!! This afternoon i will go and check on track and let you know final results.

photo
1

Confirmed success - notifications for LM have to be ON to have automatic screen ON working.

photo
1

Hi Przemek,

thanks a lot for the update. As I wrote, Locus Map needs ALL permissions granted from the phone system, otherwise, some feature may not work properly.

best regards

Michal, Locus team