Bluetooth sensors LE (BT 4.0)

astartica shared this idea 5 years ago
Completed

Is there a chance that locus get support of Bluetooth speed, heart rate, cadence, speed/cadence sensors like "Smar.t speed" form "teasi".


Because ant+ doesnt support many smartphones.

Comments (16)

photo
0

Hello astartica,


currently there is no plan for support such sensors. Anyway I changed your question to idea and we will see, if more people will be interested in this ...

photo
1

BLE Speed & Cadence sensors support would be great. One App (Locus) to rule them All...;-)

photo
2

Speed & Cadence sensor connected over BT LE will be available in next version of Locus.


Heart rate monitor over BT LE is already there, so it should work correctly.

photo
1

Super!

photo
1

Hello


Is the Speed & Cadence sensor connected over BT LE realized. Have any people tested? With which Hardware run locus perfectly?


Regards

Danjel

photo
1

I use it since June this year with Topeak panobike. Works perfect. Only issue is you have to reconnect the sensor after a stop over a minute vor so, but its not really a big problem

photo
1

Hmmm that was not good. Always i stop with bike i must go in the Menu from the Smartphone and make a reconnect? If i understand aright?


I can not use my smartphone with gloves in winter season.


Regards

Danjel

photo
1

Yes, but only after a minute or two. A short stop is not the problem. Workaround for longer stops is to turn the crank back sometimes so that the cadence sensor gets contact...

I don't know if this is an issue with my Topeak panobike, maybe other BLE sensors work different?

photo
1

This really happen? Locus should be able to reconnect automatically. I also have PanoBike, so I'll test it more precisely. Thanks.

photo
2

Yes really. Would be more comfortable with automatic reconnect. thanks.

photo
1

I never knew that BT LE cause such troubles on Android. Nice example is this - https://code.google.com/p/android/issues/detail?id=58381 - reported issue on Android dev group where I found exact description of what happen in Locus. Problem with reconnecting. Issue has 150 votes (quite a lot) and no response from Google.


Anyway thanks to one response, I found possible solution. Fortunately same issue happen on my device as well, so I hope I'll fix it.

photo
1

Hello Menion,


is the Issue in the actually Version fixed?

Can you inform us when it be fixed.


Thank you for you effort


Best Regards

Danjel

photo
1

Hello Danjel,


sorry, I completely forget on this problem. Unfortunately as I see on Google Code page, there is no change, interesting.


I'll try to find some time during next weeks and check what may be some alternative solution for this issue. In case of any changes, I'll let you know here.

photo
photo
1

Hi, connecting to a Polar H7 works pretty fine, also with track recording.

The only issue I have is, that I need to reconnect (not pairing; only like activating the connection) manually everytime I start Locus. In particular I can therefore not start track+HR recording via the widget, as I always need to go to the "real" app to activate the connection.


Any chance to add an autoconnect for track recording?


Best regards,

Philipp

photo
1

hi Menion, I think the reconnection works fine now. I didn't really test it, but on my first tours I always had connection to my BLE sensors, even after a break of 2 Minutes. Did you change anything?


And what's about some setting in Bluetooth Manager 'auto enable on start of track recording' please!

Would be great.

ciao

Benuli

photo
1

  1. Did you change anything?


Mnn .. no.


Autoconnecting ...I'm aware that this is really missing there, sorry for that. Just too much tasks to do :(

photo