Problem with BRouter navigation

Horak Tibor shared this problem 4 years ago
Solved

I do not know whether that fault, but confusing. I would like to navigate the Brouterrel the edited track below. But once you stray from the path, for example, I did not get feedback on the turn, then half of the target station navigating immediately and does not take into account the track I made itinerary. Can I redirect a deviation from the route of the track continued?

Comments (8)

photo
1

Good day Horak,


not sure if I fully understand you, anyway let's try to solve it. From what you wrote, it looks like you have a problems with recompute of track when you leave a track?


Important is what you do. You use "Navigate to" function (directly from a menu > more or from context menu of any point)? Please try to describe in bigger detail what you do, thanks.

photo
1

I'm not sure if this is related or not. (If not, please ignore this tangent.)


I'm using BRouter on the bike with Locus, and it's brilliant. Occasionally I'll miss a turn (did I not hear the voice, or was there none? Don't know.) As I keep going in the now wrong direction, it'll say:

"Track was recalculated"

[silence]

I go farther...

"Track was recalculated"

[silence]


I'm beginning to think that silence really means, "Make a U-turn". I've never heard it say that. (This is with latest Locus, and BRouter before yesterday's update.)

photo
1

Hello,, I design a 100km circular track in GPX format with the same start and destination station. Track Name "100km round." Then, data / tracks / MyRoute / "100km round". I select the track and navigating (Navigate Guide On Guide On reverse the menu). 50km misses a turn, therefore navigating to the Brouter perpendicular to the target station. Not the remaining 100 km further along the "100km round" navigate. Cycling workouts and I use the phone in my pocket. I go by voice command. So far I have used the Guide On notification. But the road to navigation loud comfortable cycling. So navigated along pre-drawn circle coach. Do not take the shortest path to the goal. Thank you!

photo
1

Hello,


hmm maybe this problem is really close to what we discuss on older Locus forum here: http://forum.locusmap.eu/index.php?topic=4506.msg35961#msg35961


Check few last posts on mentioned link, it should help. It is anyway something we discuss about and try to improve exactly for MBT purpose.

photo
1

I tried the new update. Unfortunately, no good. If you deviate from the road, first to really control the navigation along the track. But after a couple of tenths of a second immediately directed toward the goal! I do not know what could be the problem!I may get a backup file to try? Help!

photo
1

Hello,


unfortunately to check what is wrong, I need a more information, sample exported track, screenshots etc. so I may simulate exactly same problem you have (or describe you why this behavior is correct).

photo
1

Hmm hello Horák, this is nice combination of two features that little bit collide.


You have enabled in settings "Strict route", but unfortunately also an "Automatic recalculate" directly in Settings > navigation. Please try to disable it, it should help!

photo
1

Not good! Off Automatic recalculation :(

attachments photos and backup

Help me,, thank you!

photo
1

Hello,

sorry for a delay. Unfortunately I have still no idea, how may I help here more. Did you tried to disable automatic recalculate?


If I remember from your video, Locus recalculated track back to start point. In next version of Locus will be possibility to define "via points" that helps to create circle navigations and be able to use also recalculate during navigation, so it may helps.

photo
1

Hello,,


"via points" try it!

Automatic recalculation ON or OFF?


Thank you! Horak

photo
1

Please try a new version 3.10.3 and use "navigate to" function: http://docs.locusmap.eu/doku.php?id=manual:user_guide:functions:navigation:point-to-point . There is a new option to insert up to two "via points". After that you may also enable automatic recalculation. Locus will always try to correctly pass you over these "via points" even with recalculation.

photo
photo
1

Hello,


did you tried latest versions with it's

1) options to use "via-points"

2) option to change type of "recalculate" to new "Route priority" option?


Both features may help with this problem.

photo
1

"Via points" was less use it, because I plan to route the computer and get the GPX. But thanks to new developments! The Navigation screen is off on switching current event is really like. The new update with improved navigation by track problems. Navigation Priority track option is the solution. Rarely makes a mistake. Thank you!