Bug in exported GPX files ?

Pavel Hubik shared this problem 4 years ago

Recently I tried to import GPX track record files - previously exported from Locus 3.23.1 - into OkMap software. It worked if the GPX of version 1.0 was used but not for 1.1 version - error message was displayed. The OkMap support told me that the 1.1 GPX file exported by Locus does not meet the GPX specification. Namely, line (18) containing something like <gpx_style:color>#BBFF00AB</gpx_style:color> should not involve the '#' symbol. Really, when I remove '#' the GPX file can be imported.

Moreover, I am somewhat confused by eight hexadecimal numbers in color specifications, I would expect only six numbers for RGB color. Indeed, when I use, instead of the above line, e.g.

<gpx_style:color>BBFFAB</gpx_style:color> the OKMap interprets color correctly, while for <gpx_style:color>BBFF00AB</gpx_style:color> it uses a default color.

Some other Windows applications, like Google Earth or BaseCamp, import Locus GPX files without errors, but they use their own style of GPX lines, so the color specification by Locus is likely completely ignored.



Replies (1)


Good day Pavel,

thank you (and OkMap support) for a precise bug report.

Issue will be fixed in next Locus Map version. Currently it exported color in ARGB format. Correctly by GPX spec. should be RGB as you wrote and alpha channel separately as "opacity" parameter. Thanks, done.

Leave a Comment
Attach a file