Can't activate device administrator on Galaxy S5

Cegam shared this problem 5 years ago
Solved

Hi,


For reasons I don't know, Locus Maps Pro cannot be set as an device administrator anymore. In the past I controlled lock screen via Locus so I assume device administrator was set. But when I start guidance now it keeps asking to activate administrative permissions. When I tap activate, nothing happens though...

Can you please help me?


Thank you!

Replies (7)

photo
1

Good day Cegam,


please your Android device settings > Security > Device administrators. Maybe you will be able to activate Locus manually there. Let me know if it helped.

photo
1

Hi Menion,

Thank you for your reply. Unfortunately, this doesn't work either. When I tap the box, the check doesn't appear.

photo
1

And happen at least something? On my device, system ask me if I was "Active/deactivate Locus as system administrator". I've tried is also on older device with 4.2 Andorid and it works in same way as on new Android 6.0

photo
photo
1

Hi Menion,

Yes, now I have this screen (didn't have it last time I wrote here). However as for the pop-up screen in the app nothing happens when I tap "activate".

photo
1

Hmm I have just spend a while by searching on internet for similar problems, and there seems to be quite a lot of people that are stuck on screen "Device administrators" and unable to change anything.


As I read, in most (maybe) all cases helped restart of device and (or) re-installation of application. Quite weird, but suggest to give a chance.

photo
2

Hi Menion,


Thank you! It worked! For future reference

1. Backup data in Locus

2. Uninstall Locus

3. Install Locus

4. Activate device administrator

5. Restore backup

photo
1

Good day Cegam,

seems to be some crazy Android bug. Glad it works, I'll keep this solution in mind when it happen again in future. Thank you!

photo
1

Can confirm the solution. Had the same Issue on a Sony Xperia Z5 compact with Android 7.1.1

photo
1

Good day Jürgen,

please check also our manual here: http://docs.locusmap.eu/doku.php?id=manual:user_guide:settings:display#screen_on_off_control . I'm sure that information in orange box will be real source of problem here.

photo
1

Thanks. Locus is installed on internal storage, now. I guess I moved it to sd in the past what caused the issue in the first place. Reinstallation fixed it because now Locus is on internal storage again :) The data is still on sdcard.

photo
Leave a Comment
 
Attach a file