This object is in archive! 

Date error, trying to log cache from Asia

Viajero Perdido shared this problem 8 years ago

Hi. I was caching in Korea recently, and kept getting date errors while trying to log caches via the app:

1. Log Visit

2. Online: Log your Visit

3. Select log type and enter comments.

4. Leave time fields unchanged. (Here at home, I see they default to the correct time and date, and I'm pretty sure they did back in Korea as well.)

5. Leave time zone unchanged. It showed Korea's time zone with examples from across Asia.

6. Tap Confirm.

Result, from a screenshot I managed to grab:

Code: InvalidDateTime

Message: The DateTime provided must be between 2000-01-01 12:00:00 and 2015-11-19 04:19:13.

Time shown at top of phone in screenshot: 1:19 (pm). Local date is November 18. Phone has local SIM and network provides correct date and time.

So, it's complaining the date must be between 2000 and tomorrow, even though it is.

It wasn't a big deal, since I did most of my logging from the hotel room at night, the same way, using the tablet (both tablet and phone run Android 6). Using the tablet later in the day, it always worked.

Replies (4)


Hello Viajero,

thank you for a precise bug-report. This seems to be "mega-problem", that do not have a simple solution for now. has really bugged system for correct definition of timezone for logs. I¨m searching in their forum for developers and found around 10 various topics where developers complain on similar problems since 2011 and still no solution :/.

I'm now well aware of this problem and when something change, I'll fix it immediately. For now, it is needed to log a found two or more hours later, heh ...


Good day Viajero,

may you please confirm me, that current problem is solved with latest version of Locus?

Mainly because of this issue, I made some major changes in logging a caches over Locus and I believe, that also thanks to help of Arcao (developer of G4L), Locus now logs caches in correct time (even it may not look so on page).

So I hope, this issue will be solved. Thanks


Seems to be fixed*, thanks!

First I waited for roughly noon Korea time. On my WiFi-only tablet I set the TZ to Seoul, and verified that the time and date matched current date and time in Seoul. (It's the 28th in Seoul right now, 27th here in Canada.) Loaded up a Korea cache via G4L's "Import GC" feature, posted a note via the procedure above, and it was accepted without complaint. Yay!

* Interestingly (and maybe by design), when I reload the cache page on my computer here in Canada, it says the date of the log is the 27th. On the tablet (which still thinks it's in Korea), I did "Download Logs", and the log shows up with a date of the 28th.

Anyway, if you hear nothing more of this from people actively caching in those time zones, then I guess it really is fixed. Thanks again.

PS, this is with the current non-beta versions of Locus (3.16.2) and G4L.

PPS, and now won't let me log in, probably because I've been logging in from two continents at once. Argh. (EDIT: It didn't last long. All is good again.)


Thanks for confirmation, good to hear it.

Problem with time on web page is different story. Anyway if you download GPX file directly in cache page, you may see that times in logs are correct. Problem is really on web page itself and seems that groundspeak takes it's time and solution is still in far future.

Leave a Comment
Attach a file