Date format differs on phones with same settings

Bob Hawkins shared this question 2 months ago
Answered

I noticed for the first time today that the date format in my wife's Locus Map Pro alongside the calendar in Tracks>Recorded is shown as 4/7/2019, while mine is 07/04/2019. I cannot read in the User Guide or see in Settings where a date format can be specified.

Settings>Date & time on our mobile 'phones are identical.

Observation: her Locus Map Home Screen icon is the Android robot now, having updated to version 3,38,3, rather than the traditional Locus Map appearance, which is a shame.

Comments (3)

photo
1

Good day Bob,

hardly help here. Locus Map use internal Android mechanism, so it just calls "hey Android, format me time in current users localization" and what you see is the result. So most probably there have to be some differences in the setup of both devices. So summary: this time format is not set directly in Locus, but is based on the setup of your device.

The missing icon is also interesting. I'm quite sure there is no problem in Locus Map setup and it is for the first I read about this issue, so there should be some temporary problem on your wife's device.

If there will be something more I may help with, feel free to ask.

Jiří M. aka Menion

photo
1

Menion

I thank you for your reply.

Partly solved:

I discovered 'Language' in Locus Map Pro on my 'phone is set to 'Default system' whereas my wife's 'phone is set to 'English (English)'. Resetting hers to 'Default system' changes the date format to match mine as 07/04/2019, say, after restarting the application.

Strangely, however, changing my 'phone to 'English (English)' does not alter the date format to 7/4/2019, say. The one difference is that I updated my wife's 'phone to version 3.38.3 recently, whereas mine is a much earlier version.

'Language' in the Android system is set to 'English (United Kingdom)' on both our 'phones.

photo
1

Good day Bob,

thanks for the testing. I have to admire that this "problem" belongs to the category with very low priority. On first look, it is not clear why this happens when both devices have exactly the same settings. On second look, is it really a problem we need to solve?

It is possible to create a special test version that will print into log some settings that Locus Map use for formatting time, but we spend a lot of time on it and maybe result will only be, that difference is caused by different version of ROM or Android version on devices.

So if you do not mind, I'll leave it as is. Thank you for understanding.

Best regards,

Jiří M. aka Menion