Deleting trackpoint from route hangs the program

Mykolas shared this problem 5 years ago
Closed

Version 3.18.6.


1. Attempt to delete trackpoint says something like "Completed with error". Program hangs in 99% cases ater that.

2. Multiple editing of trackpoints on the route and deleting routing waypoints looked well befor the program hang. Aftre restarting the program the route became total mess (see pic in the attach)

Replies (8)

photo
1

Hmm second report with similar bug (http://forum.locusmap.eu/index.php?topic=5341.msg44823#msg44823) but I can't reproduce here without more/better description details.

Maybe a logfile would help: http://docs.locusmap.eu/doku.php?id=manual:faq:how_to_create_debug_log

photo
1

I tried to reproduce in 3.18.6.2. Trackpoints deleted OK for me too.

photo
1

I will try to make a short video how it works. Just need to get to my tablet.

The tablet is Samsung Galaxy Note Pro 12.2 (SM-P901) with Android 4.4. Maybe OS is too old?

photo
photo
1

Hello Mykolas,


sorry for a troubles. Samusng Note Pro with 4.4 Android should be ok.

Anyway video is not completely necessary. Best should be to be able to simulate problem.

So

1. share some your track as GPX

2. write us exact steps that leads to this problem, like a) delete trackpoint X, then delete trackpoint Y and voala, issue appear.

photo
1

Dear Locus Map!

Thank you for prompt answer.

I have attached two routes: source and edited.

When I edit the route by moving its points to different places, adding or removing them,

The next start of technology program shows mess with the route points. Seems it forgets the order of points during editing process.

I prepared tracks in different program (alphinequest quest) and imported this as gpx.  It was too long and hard to build the route in Locus due to slow map loading and slow reaction on edits. Done on Galaxy note 5.

But Locust is still more promising and feature rich software.

With best regards.

Mykola

On Sep 9, 2016 09:45, "Locus Map" <locus.map@asamm.com> wrote:

photo
1

Hello again.

A little follow-up on track editing.

It seems that any editing of imported track (at least from gpx) brings to problems.

I exported a track created with Locus. It has way points in it.

I removed with tags from gpx files, but program still imports gpx  with red arrow points. When I try to change track by adding or moving track points, I get unpredictable results.

With best regards,

Mykola

On Sep 9, 2016 09:45, "Locus Map" <locus.map@asamm.com> wrote:

photo
1

1. share some your track as GPX

2. write us exact steps that leads to this problem, like a) delete trackpoint X, then delete trackpoint Y and voala, issue appear.

photo
1

Good day Mykolas,

thank you for an extra information. Anyway as gynta mentioned, we still miss something we may use for test.

You wrote two posts above that you attached a GPX file, but probably incorrectly. Please pack your GPX file(s) to ZIP file and attach this zip, thank you.

Also you write about some problems with order of trackpoints after edit. Imagine we have your track imported, write me please a single trackpoint I should move to get error you talk about. Most import here is to describe your problem step by step, so I may simulate it and fix it. Thank you for understanding.

photo
1

Not sure about status of this problem, but I'm closing it for now because of more then 6 months without reaction.

Leave a Comment
 
Attach a file