Disable "All screen locks" problem

Gergy Verjux shared this problem 4 months ago
Closed

Tested the 'Disable screen lock' > 'All screen locks' setting on my S5 neo, and found a nasty bug you might, I hope, be able to fix ?

Scenario: start Locus Map > switch phone OFF > switch phone back ON > Route Planner > create a small Route > click anywhere on the Route (for instance to transform a Trackpoint into a Shaping point) > the screen flickers between the lockup screen and Locus Map.

Best Answer
photo

Hi Gergy,

Disabling all screen locks for one app is a very tricky task, regarding all Android devices (thousands of types). So, it may happen that on some types (especially older ones like S5 Neo) this setting may result in incorrect behavior. Therefore, I recommend not to use route planner in this state. Always unlock your phone regularly before using route planner. We'll go on investigating this issue though.

best regards

Michal Stupka

Locus team

Comments (2)

photo
1

Hi Gergy,

Disabling all screen locks for one app is a very tricky task, regarding all Android devices (thousands of types). So, it may happen that on some types (especially older ones like S5 Neo) this setting may result in incorrect behavior. Therefore, I recommend not to use route planner in this state. Always unlock your phone regularly before using route planner. We'll go on investigating this issue though.

best regards

Michal Stupka

Locus team

photo
1

Thanks for looking into it.

Makes the feature pretty useless for me, as I am often correcting my Route in the planner - I don't like pre-cooked Routes :-)

I will go back to 'Application pinning' for the time being.