DNF icon in map

AntMadeira shared this question 4 years ago
Answered

Hi there.

If possible, how can I make my not found caches to appear with the DNF icon in map view?


Regards,

Replies (26)

photo
1

Hi,

while "log visit" change visible "Found it" with arrow down button opening window to "Didn´t find it" and confirm

photo
1

Hi, balloni55.

Thank you for replying.

That works manually, but I would like Locus could recognise the already existing DNF caches when fetching them via G4L.

Besides, I have Locus Addon FieldNotes installed, and if I do this manually it will add a log to it, when that was already done before.

photo
1

Hi,

perhaps i missunderstand you question....

>how can I make my not found caches.......<

do you mean:

- caches you have not searched for yet ? this caches are always visible with it´s cache icon Tradi, Multi, aso.

or

- caches you have searched for, but you didn´t find them and you have logged them already "DNF" inside Geocaching.com ?

these caches are visible for me on map after import or update via GC4L as blue smiely

photo
1

It's the second option you've listed.

I've already marked them as DNF at GC, but when I download them with GC4L, they don't show the blue sad smile, only the icon related to the cache type (tradi, multi, etc.)

photo
1

>I've already marked them as DNF at GC<

to be sure, you have logged this caches as DNF at GC? or what means "marked" ?


for test download the gpx file from listing of one of these caches with PC and open it with a editor

and compare:

groundspeak : type>......


DFDC Mirost</groundspeak:text>
        </groundspeak:log>
        <groundspeak:log id="545251005">
          <groundspeak:date>2015-09-30T21:04:15Z</groundspeak:date>
          <groundspeak:type>Didn't find it</groundspeak:type>
          <groundspeak:finder id="1667155">balloni55</groundspeak:finder>
          <groundspeak:text encoded="False">Leider nicht gefunden
*

photo
1

Yes, they're logged at GC.com and they appear at their live map as DNF (with the blue icon), but not when I import them with GC4L to Locus.

photo
1

Puh, difficult task

please verify your

login inside locus/Geocaching tools/profil

and as well as in

GC4L/setting/login

both logins must be identically as your login inside GC.com where you have logged these caches DNF

If you have no success, please share a GC-Code of one cache you have logged DNF short time ago

BTW: are both apps are on current version??

photo
1

I had a problem with Locus login, because I was logged but no user was listed. I had to logout and enter again, and now my user is listed. The login with GC4L is ok.

Unfortunately, the DNF icons still don't appear in the map.

I've tested with GC6JX6V, which I've deleted from Locus databse and imported back with GC4L. Result: the icon that appears is the wherigo icon, not the blue smile.


About the versions:

Locus -> 3.25.5

GC4L -> 2.1.5.5 (c269682)

photo
1

Hi all,

I can confirm this bug (successfully simulated) and will inform Arcao, author of the GC4L addon.

photo
1

Thank you balloni55 for helping understand the problem and Michal for confirming it.

Let's hope Arcao can correct it.


Regards.

photo
1

Hi,

I've discussed it with Arcao and it seems the problem is in Locus - we have to wait one more week until Menion is back from his vacation.

photo
1

Thank you, Michal.

photo
1

Hi guys,

complicated problem to be true.

To correctly display DNF log, it is necessary to have existing field note record in Locus Map itself. This may be achieved currently only by a logging directly over Locus Map app, sorry.

Anyway, I've just made improved system little bit, so it will be possible to:

  1. import Pocket Query with own finds from https://www.geocaching.com/pocket/default.aspx , at bottom "My finds > add to queue". This fill all found and not found logs into field notes manager. This PQ anyway really contains only "found" logs
  2. import your caches as usually and it should be correctly marked as found

Hope this at least partially helps. It should be also possible now to export not found caches with it's logs from GSAK or other tool and import them into Locus. This should fill missing logs into internal field notes database and later correctly mark not found caches.

photo
1

Actually, I use the Locus FieldNotes add on, and I would expect that, at least, my DNF notes there could be used by Locus to mark the DNFs in the map. It's not a big deal, but it would certainly improve the user experience.

photo
1

Hmm as I mentioned before, DNF record visible in Field notes add-on should be enough to correctly mark caches. This does not work for you? Is is possible to send me a Locus/data/config/gcFieldNotes.db file and also GC code of caches, where you expect to be correctly marked as DNF? ( you may send it on jiri.mlavec@asamm.com or attach it here if there is nothing secret, thanks ).

Also, are you downloading new caches ( where you expect this DNF mark ) over Geocaching4Locus add-on or any other method?

photo
1

No, I'm sorry, I was mistaken.

If I mark a cache as DNF in the Field Notes Add-on it shows correctly on the map.

What doesn't work is if mark a DNF at geocaching.com and then import the cache with G4L, although my DNF log appears in the cache's logs tab.

photo
1

Oki perfect. What does not work simply cannot work because Groudspeak does not improved it's API to allow this. Sorry, we cannot help in this case.

photo
1

Ok, thank you.

Let's hope GS can improve their API about this issue (and many others).


Regards.

photo
1

It would be great to have an option to toggle this behaviour. I only want unlogged caches in my fieldnotes. Therefore I delete them after logging. Now, all my DNFs keep showing up each time I load an GPX :-(

photo
1

Hello,

may you explain a problem here?

a) why to keep only unlogged field notes in app?

b) what is a problem on correctly marked DNF icons on imported caches?

photo
photo
1

I'd like to disable this new feature. It does interrupt my normal workflow.


When I now do my daily export from GSAK and import it to locus I first have to delete all these files fieldnotes. Because later I import all fieldnotes back to GSAK.


Please let me disable this function.


Thanks Wolfgang

photo
1

Hi Wolfgang,

I do not perfectly get where is a problem? Why don't you simply export only new logs? You may disable display of already "used" logs (where belongs also automatically created logs during import) in top menu.

photo
1

Hi Menion,

the funny thing is, that I don't know what you mean ;)


Maybe it has to do with the fact that I use Fieldnotes Pro Add-in.

There I see e.g. DNF Logs and found Logs when I import my GSAK exports. Earlier this was not so.


When I now export fieldnotes pro and import them back to GSAK I have these Logs twice, three times,.... and so on.


So currently I have to delete all these Logs in fieldnotes.


I want to have my Logs to the caches. But fieldnotes are notes that I write in the field. After importing a field note it's a so called log.


In other words after I logged a cache with it's field note it's no longer needed as field note because it's now a log.


Hope you understand what I mean.


Thanks Wolfgang

photo
1

Hello,

add-on, oki. Anyway this cause no difference.

In add-on, before you export field notes out of app, you have to select them. At top is checkbox that allows to "Select not logged". This may helps here.

About naming log vs field note .. understand, thanks. I'll consider renaming to something like "Log & field notes manager".

photo
1

Hi Menion,

I did not replay because I tested your workaround with the checkbox "select not logged" for some time.

After a few tests it seems to work but it's extrem hard to keep any overview and it does not make much fun to navigate inside the fieldnotes. As you can see (attached screenshot) I have almost 10000 fieldnotes before the change of locus I had only the few ones I logged on my tour.

Please add a little switch in the config file to switch the functionally back to that what it was before. That would be great.

Thanks Wolfgang

photo
1

Good evening Wolfgang,

hmm, I still see no complications here. When you use this add-on, what about tap on top "filter" icon and selecting "Selected logs > Not logged"? This should cause that you will see only "Not logged" notes. So same logs as before this improvement was implemented, right?

photo
1

Uuups we spoke about different things :/

I thought you mean the box to mark the logs I never used the filter button. I didn't really mention a filter here :o

It looks great and seems to solve my problem :D And it seems to be persistent after a restart of locus, that's important. I guess that's pretty fine for me now. At the moment I do not see any slow down of these big fieldnote database.

Only two little things I just mentioned but I don't really care about it. The summary on the top seems not to care about the filter - but this could be design.

And when I mark some field notes and do a refresh (wipe down from top) everything is now unmarked.

Thanks so far for your great support. I think it's solved and I'm happy back again.

Thanks Wolfgang

photo
1

Wolfgang, I'm really glad we found an working solution for you, because I consider import of field notes as really useful step ( mainly if someone use nice stats that are available in Field notes add-on ) and really wanted to keep this feature as is. And seems I can :).


Perfect!

photo
1

Hi Menion,

unfortunately I'm still not happy. The filter is persistent that's great. But also the date is persistent that's bad.

I choosed in the filter "whole period" and from then it's fixed to the current valid period :( So I have to change the filter every caching day.....

I spoke with others using locus and they also mentioned that there changed something but they thought the problem is that they made something wrong by themselves. They are just user - nothing more.

photo
1

Hello Wolfgang,

I'm checking it and agree that for a "whole period" setup is little weird. This is anyway problem in add-on (made by independent developer) and not in Locus Map (made by our small team). As I see, it is possible to set "from" and "to" dates manually, so it is possible to set "to" date to some far far future and forget on filter, right?

photo
1

Hi Menion,

you're right it seems to keep a date in future :) I'll test this the next days. I don't know why I did not have this idea by myself :o

Thanks Wolfgang

photo
photo
1

Hello Jelle


Yes, for me it work

Wolfgang


c4b645c80c988fb2c9203af1f46a32f3

photo
1

Mmh strange, by my it not work.


In the offercial geocaching app I see the sad face.


And in Locus Map pro not. Or is the reasson that Locus Map pro read only 30 logs?

photo
1

It was working for me strangely lately as well.

Try to "download logs" instead of "update", it may work as a workaround.


May be related to:

https://help.locusmap.eu/topic/last-updated-is-not-updated-any-more

photo
1

Where can I find the option "download the log"? Updating isn't work.

photo
1

Right under the update option in geocache page

photo
1

Strange my page looks different

photo
1

Indeed it does. But maybe it doesn't matter, tap on the three dots connected by 2 lines - next to the "arrow up" you tapped on your screenshot.1

photo
1

Aha I thought that was the symbol for share it. But did not know that there where more options ☺.

I have now download the logs, and update the caches again.

But sadly it didn't work.


My log is there.

photo
photo
1

some ideas:

- are you logged in with your cacher name "jelleruben78" inside locus and GC4L?

- did you run "update cache"?

photo
1

Yes I logged in, yes I have updated the caches

photo
1

Hi Jelle,

please check you are logged in also in Locus Map, not just in G4L addon (check it in menu > more > geocaching tools)

Michal, Locus team

photo
1

I am logged in.

photo
1

At the moment, we're unable to simulate the problem. Awaiting more feedback regarding this issue.

photo
1

Must you get feedback from me or intern?

photo
1

Not just from you, also from other users. We need to know if the issue is an error in app that would affect generally more users or just an error in your device that affects just you.

photo
photo
1

Allright. I don't know what I more can say or let youknow.


I been loggedin on two places G4L and in Locus map (you have seen my screenshots) or must I set more settings else where?

photo
1

Have you logged DNF through Locus, or through website?

photo
1

From the website on the website can I see the sad smileys

photo
photo
1

So I have reset Locus map pro.

And login on. I see e my name on G4L addon and by "menu > more > geocaching tools".

I turn "live map" on.

Sadly I don't see the DNF smiley's.

Do I forget something. Or is there aproblem? Or are the DNF only shows if your register the DNF in Locus Map.

photo
1

I just tested if "Live-map" shows blue DNF smileys. And it does.

within GC4L > settings > filter:

- Did you turn off any cachetype, size, difficulty, terrain (otherwise this caches won't be shown)?

- Did you turn on "show deativated caches"? (otherwise those caches and some extra caches wont be shown)

GC4L > settings > receive data:

- Did you turn off "DNF, NM, NA-caches switch off"? (otherwise in combination with the option above some extra caches wont be shown)

photo
1

Yes all have been set like that

photo
photo
1

I tested this strange behaviour of DNF-smileys in detail and hope that it could be solved Locus team:

1)

If importing a GPX-file of a DNFed cache AND there's no field-note of this cache in Locus, then there's NO blue smiley on the map as well as on top of the "Basic info" tab of the cache. => NOT OK

2)

If importing the same GPX file a second time, Locus displays a blue smiley on map + "Basic info" tab, cause after the first import Locus for some unknown reason created a virtual field note ()which can not be uploaded to geocaching.com) which triggers the display of blue smiley. => OK

3)

If creating a field note with a "DNF-log" of a former unlogged cache: Locus changes former Cachetype-icon to blue smiley. => OK


4)

If running Live-map, the behaviour is like in 1). If there's no field note present, icon is Cachetype. If fieldnote is present then blue smiley. => DEPENDING ON API-CONTENT

In case of 1) Locus should also display a blue smiley if there's no field-note present, since it has already got the necessary DNF-info within my DNF-log in the GPX-file.

In case of 4) I'm not sure if it's possible, depending on if API sends a DNF-info. Maybe also depending on if API send some of the latest logs. If API sends DNF-info or my DNF-log is withing this latest logs, then also display a blue smiley.


There's been another old thread, which also covers this problem:

https://help.locusmap.eu/topic/dnf-icon-in-map

Leave a Comment
 
Attach a file