download of large map never shows 100% complete

Andrew Heard shared this problem 6 years ago
Solved

When downloading this large 1.8GB map the progress bar got to 98% and never further. I was concerned the 20 hour download had failed 20KB from the finish.

0bf5fe827a8b2a4dfd8af2c0354aad46

When I checked the menu for download progress it suggested all completed:

2cb2c045502625c92a71781b1c78162d

It appears the statistics are not refreshed to 100% after the final data transfer?

Replies (4)

photo
1

Hello Andrew,


you wrote that "Download failed". What does it mean? In Menu > Maps > Offline was new map downloaded? Statistics on download screen may be (should not be of course) wrong. I'm quite surprised by your 20 hours. If it takes so long, is it necessary to download biggest map in Store? :). Anyway this is not my problem ...


During 20 hours may happen almost whatever and is almost impossible to simulate exactly same problem as you had. If you download any smaller map, then no such problem happen?

photo
1

No, I didn't say "Download failed". I said "I was concerned...". I should have added for clarity the download did succeed, sorry.

My point was the statistics were not refreshed at the download completion. So maybe this suggests refresh issue only happens with for very long download time? Maybe tedious to simulate (not impossible), and I agree minor problem, but I would have thought it may be a Locus problem - "download succeeds but progress doesn't show 100%"? Floating point or loss of accuracy in integer calculation - it's happened to me as a programmer before.

Correct, smaller maps have not had same problem.

I wasn't complaining about the download time.

photo
1

Ah I was worry that download was not success.


I now remember that something similar also happen to me some time ago during longer download when screen was turned off during most of time. Hmm I'll try to look at it, thanks.

photo
1

Download was a success.


Just statistics never displayed 100%, and no indication download had completed.

photo
1

Thanks, as I wrote - I've probably found a problem, so fixed.


You wrote "no indication" - hmm maybe some notification to system status bar should be useful. I'll think about it, thanks.

photo
photo
1

Ah I've probably found a problem that caused this. After some quick test, all seems to work fine. Thanks for report!

photo
1

When I download vector maps via openandromaps into Locus (which I did yesterday in some 10 runs) it all downloads up to 100% (so Locus shows the % while downloading) and then starts extracting the downloaded zipfile, also up to 100%.

photo
1

Oki, but this is completely different system then directly over Locus Store.

photo
photo
1

This bug has not been solved. I have downloaded many maps since 2 years ago, all fine (from memory), but today I downloaded over Wifi connection LoMap from the Store (Oceania > Australia > Queensland.osm.map 256MB + osm.db 43MB) and the download progress became stuck at 44% 167MB for 30+ minutes which I thought was strange. I tried switching between apps to maybe force a final Locus screen refresh but no change; I tried pause/ resume button, again no refresh. So I returned to main screen and notification said map download successful. So even though original topic was for huge 1.8GB download stuck at 98%, this recent experience is far more typical of an average user map download. The phone screen was mostly turned off during download; I turned on every now & then to check on progress. FWIW using Android 5.1, Locus 3.30.3 RC1.

42005e2ac9f811bb22d2acd4939d84d4

Leave a Comment
 
Attach a file