Downloading MBtiles through locus-actions link not working anymore

Paulo shared this problem 3 years ago

The ability to create download links for custom made maps (like MBtile maps) using locus-actions is a great feature. However, it does not seem to work anymore. Did anything change in the xml format?

For example, the link locus-actions://http/ worked up to recently. When opening in a browser on android, it downloaded the map_ethiopia.mbtiles in the right folder in Locus. However, now it initiates the download it seems, but than nothing is downloaded.

Best regards,


Comments (3)


Good day Paulo,

I'm checking mentioned example of Ethiopia map.

Link on your web page lead to this xml file: . Link for download map received by this XML file is then . But unfortunately this link is not valid and map do not exists - server returns "404 Not Found" error code.

So please check Url on map on your server.


Good morning (or whatever part of the day you are reading this), thank you very much for your quick feedback. There was indeed a problem with the link, something I should have checked first obviously. All works as advertised again. p.s not sure how to set a ticket to solved, so I'll have to leave that up to you.


Hello Paulo,

glad to hear it. Ticket solved (I'll mark it ;) ).