During track Import, Fill Altitude does not fill altitude of all tracks

Nick Suter shared this problem 9 years ago

When importing a KML file without altitude data (see attached), LOCUS only fills altitude for some (a few) of the tracks.

I enable fill altitude when importing, and save to folder '1'.

Attached is a screenshot of one example of a track that did not fill altitude.

I have these srtm files:



Thanks for investigating this bug.

Replies (3)


"Locus don't download any SRTM files during import.

Offer for downloads is only when you use "Fill altitude" for single point/track."

...but Locus offers "fill altitude" as import option.

That's a little bit ...

dirty workaround:

DL first all your SRTM files

In your case:






Ok, well I don't know any user will know to do this, and it would be nice if locus did this for them when importing.

Nice find gynta. I'll go over to USGS and get those files.


Good day guys,

thanks for report. I'm aware of this issue. Solution requires extra work and I do not know exactly how to simply solve it. In time of import, is not known which areas will be required. So Locus cannot ask for HGT files before start, because there is not know information which are needed. Asking for files before every track should be an weird solution so only solution I see should be some "batch fill altitude" right after all tracks will be imported.

Hmm I'll see if more people will have troubles with this quite rare issue ...

Leave a Comment
Attach a file