Failure to change default directory for only certain folders (srtm, mapsVector)

Jonathan shared this problem 3 years ago

Hi, I'm using Locus Map Pro version 3.16.2 on Android 6.0. I've been a Locus user for many years and love the app.

I use a phone without a lot of internal memory, so I rely on being able to put much of the locus data on an SD card. Unfortunately I'm having problems changing the default directories for certain items. This is very strange, and I've observed this behavior on two separate phones to confirm the bug.

The problem is, for certain directories (mapsVector, data/srtm) I cannot change the default directory. However, it works for other directories (maps, mapsOnline, mapsVector). Here's how the process looks. The directory selection screen looks like this:


Now, when I try to change a directory for maps, mapsOnline, or mapItems, it comes up with a handy folder selection UI, and the process works. It looks like this:


However, when I try to change the directory for mapsVector, or data/srtm, it comes up with a different UI, which looks like this:


Then, when I try to select a folder, there is a pause and the message "process successful" flashes on the screen. However, the display clearly shows that the default folder has not changed. I can confirm that it has not changed by downloading maps or srtm data, and seeing that it goes into the default location in internal memory, not the one I tried to select on the SD card.

It's very frustrating because I am able to set some of the folders to default to the SD card, but not others. This means that certain maps and files go to my internal memory, and others to the SD card. Please help!

Comments (2)


Good day Jonathan,

sorry for a complications. I'm sure, that issue will be fixed in next version because I've discovered same problem on new devices with Android 6 as well.

Please keep in mind, that on Android 4.4+, Locus is unable to write to SD card directly as was previously possible. Only solution is weird internal mechanism that is already used for vector maps, SRTM data and backups. These are places that use Android-made directory selector and where you also have a problems.

Anyway let me know after release of new version, if all works as expected. New version is planned on middle of May. Thank you.


Wow, thanks for the fast response and great support. I look forward to the next version. Keep up the great work!



Reported this problem few weeks ago via pm (hangout) - do you remember?

Normal error logfile helpes here? or we need a "special" Locus version to see "special" read/write errors in log?

edit: to late :)


Ah it was this? Hmm, but this should already be solved in latest Beta version. Ah maybe not ... next beta, oki? :) Thanks