Geocache listing Option to 'Open in web browser' no longer working

Ian Leask shared this question 11 days ago
Answered

Locus Map ver 3.44.3 Geocaching4Locus ver 3.0.5

The problem below started after a Locus Map update probably a couple before ver 3.44.3

I have copies of downloaded geocache listings in my Points folders Sometimes when I am viewing a geocache listing I wish also to view the details on the Groundspeak web site

Currently for any listing, when I tap the GC code on the Basic Info page a popup box offers the option to 'Open in web browser' When I tap on this option Locus Map simply downloads another copy of the geocache information


Previously when I tapped on 'Open in web browser' the cache listing was opened (as expected) via the phone web browser directly on the Groundspeak website

Why is the 'Open in web browser' option no longer working properly? Or has the method to do this changed?


Many thanks

Comments (4)

photo
1

Hello Ian,

it looks like you enabled Geocaching4Locus as default application that is able to handle click on this button. To "fix" this, please open system settings for Geocaching4Locus add-on and tap on "Clear defaults" (or similar) button. This should help.

Jiří M. aka Menion

photo
1

Thanks Menion for your very prompt reply


I cannot find a 'Clear defaults' button or similar in the G4L Settings


Regards

Ian

photo
1

Hello,

check system settings, not the settings in Geocaching4Locus application. Something like (on Android 10) "System settings > Apps and notifications > Geocaching4Locus > Advanced > Open by default > Clear defaults". Little hidden, agree.

Jiří M. aka Menion

photo
1

Ok found the Android Default Applications settings and Cleared Default for G4L but still did not go to Groundspeak website Restarted phone made no difference

Tried the same for Locus Map but problem remained

The problem first occurred after  Locus Map update several months ago

This does not need urgent fix Menion As a busy guy you have better things to do Maybe one day?

Ian

photo
1

Hello Ian,

this is weird. "Open in browser" is a really simple method that just should work in the case, you have any standard web browser. For example on my device, I always get the offer if open in "Chrome" or "Geocaching4Locus". Do you use chrome? If not, may you give it a try? Maybe it is just a problem of web browser you use, that is (after some update maybe?) unable to correctly handle request from Locus Map app.

Menion

photo
1

I use Chrome

Tried updating Chrome to latest version but this did not resolve problem

I do not get offer to use Chrome or G4L It just downloads another copy of geocache listing

Ian

photo
1

I've just noticed that open of this link is not defined under "Defaults", but under "Open supported links" option. Do you have in your device same menu?

/655cd49e8c90b99cf4db3e9d80cb9a95

If so, try to disable this for G4L.

Or, as I though about it, you may try to install from Google Play any other web browser, like Firefox. Just the fact that there is another browser in your device, should force system to display required dialog with choices.

photo
1

Bingo You have got it!

I went to Settings/Applications/G4L/Go to supported URLs and changed 'Via this app' to 'Always ask" When I tapped on GC code I then had options 'Download to Locus' and 'Chrome' The Chrome option went to Groundspeak


Interestingly when I tried another geocache it did not ask but went directly to Groundspeak That's all good

For the record I already have a second browser - Samsung Internet


Thank you for your persistence to solve the problem All very strange when it previously went directly to Groundspeak without this change to settings

photo
1

Hello, perfect.

When you get this offer, there are always two choices: "Just once" and "Do not ask", so be sure to tap on "Just once" in case, you want to see this "Choose dialog" next time.

Menion

photo
photo
1

I have Android ver 6.x so do not have option to choose ‘Just once’ or ‘Do not ask’  However I can just choose ‘In other app’ and I can then select (in my case) c:geo or Chrome  Anyway the original problem is fixed

Thanks

Ian

From: Locus Map

Sent: Friday, 15 May 2020 6:05 pm

To: Ian Leask

Subject: New Comment in "Geocache listing Option to 'Open in web browser' nolonger working"

photo
1

Sorry Menion For last comment I tried using direct email and messed up Is there any way I can edit to clean this up?

Ian

photo
1

No problem, leave it as is :).

As you wrote, the problem solved = topic closed.

Feel free to create a new ticket if any problem arises.

Have a nice day and stay healthy!

Menion

EDIT: I've just delete this long unwanted post.