Geosetter Image Save NOPE

Ron Carmichael shared this question 4 years ago
Answered

I am hoping someone knows the solution for a problem that is probably NOT caused by Locus, but IGHT be related to Locus, as I am working with an export from Locus. I've tried signing up/logging in at the Geosetter Mantis sight, not just yet granted access where I can then ask this question. Hoping someone has run into this before and has a solution.


Trying to use a Locus-recorded track and photographs taken to Create POIs, in order to give archers a kmz. file that shows the trail and photos embedded for the targets - for an upcoming field archery tournament (over hill and over dale, shooting at paper targets on foam bales).

I did a trial once, successfully thanks to help from Wolfgang up here who shared a "how to" using Geosetter. But now....that it is getting down to the wire where I HAVE to get this done :) ,

... I'm running into something weird when I edit the data for photos taken in Locus as Create a Point, changing the name, description, etc. , and choose to save the changes. I'm getting an error message I don't understand... Something like this screen capture:


0cf7dd1918ca99a943682403a298bce1


I get these errors in a popup:


Error: Error reading OtherImageStart data in ExifIFD - F:/fieldproject/June_6_FITA_field_range/files/point_9_1431177188466.jpg

Error: Error reading OtherImageStart data in ExifIFD - F:/fieldproject/June_6_FITA_field_range/files/point_9_1431177188466.jpg


Note I'm only doing one image for the above. :) I discovered this refusal to save, first after doing 26 images, then 17, then ONE :) ....

ALong with the above, the popup rejection has:

C:\Users\A.Ron Carmichael\AppData\Roaming\GeoSetter\tools\exiftool.exe -@ "C:\Users\ABDCD~1.RON\AppData\Local\Temp\et31B62F9C.arg" -common_args "F:\fieldproject\June_6_FITA_field_range\files\point_9_1431177188466.jpg"


-EXIF:GPSLatitude=30.35257407

-EXIF:GPSLongitude=-97.83585328

-EXIF:GPSLatitudeRef=N

-EXIF:GPSLongitudeRef=W

-EXIF:GPSMapDatum=WGS-84

-EXIF:GPSVersionID=2.2.0.0

-EXIF:GPSDateStamp=2015:05:22

-EXIF:GPSTimeStamp=19:16:27

-XMP:GPSLatitude=30.35257407

-XMP:GPSLongitude=-97.83585328

-XMP:GPSVersionID=2.2.0.0

-XMP:GPSMapDatum=WGS-84

-XMP:GPSDateTime=2015-05-22T19:16:27.25Z

-XMP:Creator=

-XMP:AuthorsPosition=

-XMP:CountryCode=

-XMP:Country=

-XMP:State=

-XMP:City=

-XMP:Location=

-XMP:Artist=

-XMP:Description=30 meters

-IPTC:CodedCharacterSet=

-XMP:Instructions=

-XMP:Title=Target 04

-XMP:Headline=shoot From Here

-XMP:Credit=

-XMP:Rights=

-XMP:CaptionWriter=

-XMP:Source=

-XMP:BaseUrl=

-XMP:Category=

-xmp:rating=

-xmp:ratingpercent=

-XMP:Label=

-XMP:CreatorAddress=

-XMP:CreatorPostalCode=

-XMP:CreatorCity=

-XMP:CreatorRegion=

-XMP:CreatorCountry=

-XMP:CreatorWorkTelephone=

-XMP:CreatorWorkEmail=

-XMP:CreatorWorkURL=

-execute

-overwrite_original

-P

-L

-EXIF:ImageDescription=30 meters

-IPTC:Caption-Abstract=30 meters

-IPTC:ObjectName=Target 04

-IPTC:Headline=shoot From Here

Comments (6)

photo
1

Good day Ron,


unfortunately no one from developers team behind Locus do not use GeoSetter application, so sorry, but we personally cannot help. Maybe @balloni55 or anyone here on help desk may helps?


Did you tried to contact developers of GeoSetter itself? http://www.geosetter.de/en/help/ . I'm sure they will be able to give you correct answer. If this issue will be caused by Locus itself, feel free to contact me here with some extra instructions, I'll gladly fix it.

photo
1

Hi, Menion - thanks for writing, and to be sure, Wolfgang has been VERY patient and helpful as I struggle to create the gmz I need to, for this FITA Field archery tournament I am conducting for the Texas State Archery Association. I did manage to sign up and log in, and post the question about why I can't edit the photos in Geosetter (Adding the photo name "Target 1a", a description "35meters uphill, take bow with") and get them to save.


I understand the need to use what LP records/photographs, and then put it into Geosetter, if I want the ability to have the photos pop-up with the desired information, when viewing in Google Earth. LP is a really neat app, I had no idea it was available until just a month or two ago, but love it for years! I know a little programming for a lot of different things, one can say I know just enough to be dangerous :) :).

photo
1

I'm checking more precisely your error and found this discussion


http://130.15.24.88/exiftool/forum/index.php?topic=4936.0


Which leads to this info in ExifTools FAQ : http://owl.phy.queensu.ca/~phil/exiftool/faq.html#Q20


Just don't forget to do any backups before :).

photo
1

Interesting. I just tried making a change to ONLY one field, the Description's "Object Name", by typing "1b" in it, and when I try to save it, I get the same error message. So the rotating of the image is not related to the error message. As you said, this is very likely a Geosetter issue.

And yes, always work on a copy of the original file! I caused my first software disaster for myself in 1980 on a database with a 720k floppy and a flatfile database. That still does not keep me from occasionally having to swear at myself even today. ;)

The only reason I use the geosetter, is so that in Google Earth, each point I created will have a thumbnail image of that point so the archer can see they are in the right place to be shooting arrow at target, and study the track before they leave the house. Maybe there is some feature of Locus pro I do not use properly, that would make it so? The track and the points themselves display perfectly as desired in GE, just no pictures. Is there another way to link the photo to the point so it "pops up" on a double-click in GE?

That example GMZ on the dropbox link I posted is very large, with the photos embedded, but they just are not displayed with the track?

photo
1

Hmm did you tried to attach photo to any point in Locus (tab "attachments" in screen with point details) and export result to KMZ file?


Anyway there is a known, not yet solved issue in Google Earth, that attached photos are not clickable. I now do not remember correctly what was a problem, but I just remember, that something won't work as expected.


Anyway you may give it a try.

photo
1

Editing the photos in Irfan View ("i","i" to access the IPTC fields), rotate the image to upright, Ctrl-S saves, then Geosetter exports the combination of waypoints, trackpoints, images, into a lovely KMZ where the icons on the track show up and are clickable, bringing up the photograph including the edited IPTC values. Not the most elegant automated method, but it works very nicely, and my archers seem to like it... Thanks for Locus Pro - it's cool... I would attach the kmz as a zip but it's about 16 megs in size... You can always find a copy of it on a website I run - http://www.texasarchery.org/L1/GETracks.html