Going back from WP is (too) slow in 3.43

R5O.nl shared this problem 2 months ago
Closed

I just installed the new 3.43 and as usual I used it for OSM work: making notes, WPs in the field and at home using the OSM editor to update OpenStreetMap; what I then do is processing the WPs of the day and move them to another dir called 'old'. And then push 'back' to go back to the map view. Well, this last step (back to map view) is suddenly painfully slow. Especially for me as 'strange' user of Locus doing a-lot-of moves of WPs between directories. I just tested by restoring 3.42 on the same device: 3.42 is 'fast' as usual.

Comments (5)

photo
1

Also creating a new WP is more sluggish now, in 3.43 compared to 3.42.

photo
1

Hello,

interesting, there should be no significant change in this functionality. About how much "slow" we talk? I see, there may be new exactly 1-second delay in most cases, that try to solve unexpected crashes on some devices. This should anyway not be a significant difference.

I have also "work in progress" new screen for editing points which will hopefully be a lot faster than the current one. Anyway, this will take some time.

photo
1

Yes, I reckon I run into that 1 sec thing you now refer to. That is the amount of time I am talking about. Again, as I am managing many points at the same time (eg moving from dir to another dir, creating a new WP) such latency imm. gives a worse user experience to me.

photo
1

Ah oki. Do you know you can move & copy points between folders in batch, that will skip this additional delay as well and is almost instant.

I'm worried that I can't help too much here. I've reduced this additional delay into half of second to next version and I'll monitor crashes that previously appeared. If they anyway appear again, expect increase back to this one-sec, because I believe all will agree that rather a small delay than random crashes.

photo
1

OK, thanks for attending. I will await the next version and also look into that batch actions. Tnx