Guidance keeps screen on

Tim Finnegan shared this problem 5 years ago
Solved

Well , I have testing guidanance in 150 km bike ride

In straight parts of path it's OK. Screen is off and gets ON only in key points giving sound signal (notification)

But in curved parts (lots of turns) screen goes ON very often and without sound signal - so it is not point notification. I have turned off any guidance notification in guidance settings but screen keep goes on. In some points I was not able to turn it off manually - it goes on immediately! Only turn guidance OFF can help.

Thanks to powerbank, it save my phone :о) But what is this?

Comments (8)

photo
1

Good day Tim,


sorry for unexpected troubles!


This works in described way with latest 3.9.0 version? If it was with older 3.8.2 version, please try also latest version. It won't be probably perfect, but I believe a lot better!

photo
1

Get update to 3.9

Issue still persist.

Make some experiments:

1. It is option Display->screen on\off-> turn on when notified on a track

By turning this option off screen won't goes on in "curved" places, but it still off in key points too. Though notification sound exist

POI seemed to work well.

2. 30s screen off when idle doesn't work at all. Only 10s in every case. Now "always screen on" work as must work - keep always screen on. So I have 10s on screen or always on screen.

3. Merged with track POI become hidden when guidance along track is activated

photo
1

+1 little issue - if track use folder style its style keep changed in guidance mode. If track has his own defined style all is OK - style not changed.

photo
1

Hello,


1) So it works correctly, right? When you disabled "turn on when notified on a track", then Locus do not turn on screen in case, some notification appear.


2) sorry, I'm not sure I fully understand. What timeout you have set in your device settings?


3) yes, you are correct. Unfortunately I have no simple solution on this problem now.

photo
1

1) I want only notification in some key points ( blue dots) , not in all points. In other (not blue dots) points screen goes on without notification and in some places (high points density) screen is on almost constantly. We need some guide information only in key points , isn't it?

Is it possible to get screen on ONLY when I get notification defined in guidance options? (out of track and next point).

2) Device timeout is 30s too . Just test guidance walking by feet - screen goes on and after this turns off in 10s. In previous versions was possible to use option "always screen on" and it magically give us desirable timeout :) but now it wors as must work - keep screen always on

some times is screen keeps on longer but this is because unneeded guidance points -point without blue dots , in this points screen goes on without notification

3) well let's use POI in external folders , not a big trouble :о)

photo
1

N2 became clear! it is device lock option . You may choose to lock screen with draw pattern or slide or password. I have draw pattern. When I change unlock to slide Locus timeout became correct! 30s!

So draw pattern unlock somehow interfere with Locus timeout.

N1 stay unclear. screen goes on (in some "not blue dot" points ) without notification even if next point notification is off. If notification is on , I get notification too (in blue dots). But how to get get ONLY notification in "blue dots" points?

photo
1

Hello Tim,


very useful information from your point 2., thank you!


About issue with "screen on". Are you using guidance or navigation? Both system should turn on screen when you get any voice notifications, plus:

- in guidance, screen is turned on also when you are passing closer "blue dot" waypoint

- in navigation, screen is turned on also when you are 5 seconds before cross

photo
1

Guidance. And screen turns on rather far from "blue dot" , in some "curved" place of route. and too often - I cannot turn off screen manually , it just turns on again in few seconds. I cannot understand what does these points mean. I can turn off this behaviour only by turning off " Display->screen on\off-> turn on when notified on a track". But in this case I don't get any notification too.

photo
1

Hello TIm, sorry for a late response.


Unfortunately I need to simulate same problem as you have. Is it possible, that you export and share a GPX file with your track with me? Together with some instructions, what I need know. Thanks

photo
1

No problem, any track and any info you need.

photo
1

In attach small test track. I have guidance along this track and got a number of "screen on" not in blue dot points , without notification.

It is very short so it will be no problem to find these points.

P.S. cannot attach file . So it is here


https://drive.google.com/open?id=0B_FDS3w1R__ZQV95c212V2RYaDQ&authuser=0

photo
1

Tim Finnegan P.S. cannot attach file . So it is here


file extension *.gpx not allowed

*.zip is ok

photo
photo
1

Hello Tim,


your topic is small "skeleton in my wardrobe". It is quite complicated to simulate it and I'm unable to find any existing issue around this topic.


May you please try guidance with similar settings with latest 3.9.3 version of Locus? If there still be some issue, do for me a Menu > More > backup manager > backup of settings. So I'll have exactly same settings as you and I'll try to simulate this in the field.


Thanks you!

photo
1

Ok, I will try it. Thanks

photo
1

Well in new version I've got same issue.

Screen goes on without notification (just on switching to next point as I can understand).

I can turn it off by disabling "Screen on\off control-> turn on when notified on a track" but in this case screen still off on next point notification too (there is a sound with off screen).

Is there any way to make screen on ONLY when I get sound notification on next point? This notifications works on blue dot points.I don't need screen on in other points.


This is my config:

https://drive.google.com/open?id=0B_FDS3w1R__ZaFR2dkdFb29jRTA

photo
1

Hello Tim,


thank you for your config. Weird is that even with imported backup (so with your settings), I was unable to simulate this problem. Because similar problem reported also one users on old forum, I decided to dig a deeper into this problem. Result is a changed system for notification (and also "screen on" control) for guidance as I wrote here: http://forum.locusmap.eu/index.php?topic=4601.msg37945#msg37945


So if you will want, new Beta version is out, or you may wait till next public version probably next week.


Sorry for a troubles and thanks for your patience.

photo
1

Great news! Will test new version and report here

photo
1

Hello!

With the latest version all seems works well! Just as I need - screen goes on only with sound notification in blue dot points.

Great job, thanks!

photo
1

Perfect, so maybe finally ... :). Thanks for confirmation!