Guiding line (arrows) visibility and zoom level?

henkvanderspek shared this problem 8 years ago
Solved

When I set guiding to a nearby point (less than 1 km) I always see the guiding line with arrows (in any zoom level).


When I set it to a point at say 16 km I only have a (thin) straight guiding line and when zooming out to level 14 I get the arrows back. I need the arrows for visibility at all zoom levels.


The further away the lower zoom number I need to see the arrows.


1. Is there a reason for this?


2. I am using this in the config file: guiding_path_symbol=-16.0|-6.0|14.0|0.0|-16.0|6.0

Replies (10)

photo
0

i ve seen that as well. the thin line which replaces the arrows sometimes must be a bug. its basically invisible.

photo
0

:)


guys this is not a bug. It`s in Locus almost since begin. After around two years I discovered that android do not handle correctly very long lines that I sens him to draw. So for example, if you zoom in really a lot, so line will grow from few pixels to few thousands of pixels, Android is not able to crop this line correct and start to be laggy. So I did this ...


Anyway I`m changing this to "problem" and mark it as a solved, because now I`ll crop line by myself and draw only a small visible part

photo
0

Menion, I remember you already referred about this some time ago. Still I do not understand the actual problem. The screen has a certain size and only on the screen the line with arrows on it needs to be displayed.


It shouldn`t be too difficult to give Android an object to draw with a length which is visible exactly on the screen and not a lot more which would anyway be invisible.

photo
0

there is no problem now, as I wrote - solved

photo
0

ah, this means that I can also have a e.g. 100km long guiding line?

photo
0

in current public version, line longer then 5000px change to thin line. In my current version, I crop line by screen border so it will always looks correctly

photo
0

Are you doing this for all the lines? Also the lines to waypoints? Does the problem that I occasionaly have with disappearing lines have anything to do with this?

photo
0

OK, super. I will wait for the next update!!

photo
0

so I spend few hours on some optimizations that mainly affect lines for caches ...


rvheddeg: I responded you over support email. Anyway I hope that these changes will help on your problems with hiding of the lines.


So in next update ... ;)

photo
0

Solved in 2.9.0/2.9.1 Thank you.

Leave a Comment
 
Attach a file