How to copy all data from one mobile to another?

ulmus shared this question 2 years ago
Answered

I met some problem...


I have my old LG L9 with data on the sd card, now i bought galaxy S6 with no sd card.

I copied all locus folder from sd card into pc and connect S6 with usb, found folder:

android/data/menion....../files/locus/

i copied my data, maps, themes... but get message that some folders are wrong and have no recorded tracks :( maps are good, pois too, themes too, but have no recorded tracks :(

where did i go wrong?

Comments (10)

photo
1

Good day ulmus,


screenshot with "message that some folders..." should be useful here. Anyway if all other works fine except single database file for tracks that is stored in Locus/data/database/tracks.db, then I really suggest to check if this file is correctly copied to your new device.

photo
1

That message was shown only once, after running locus for the second time it is gone and it is showing no more.


i think i copied it in the right way, just to the destination folder, just like the others files.

In other way: can i copy all files from \Locus\... folder or i must not copy some files?

I will try to install once more app and do copy again and write down message if it will be shown.

photo
1

There should be no problem when you copy all files.

Re-install of Locus won't help here probably.

You saw this message just once and now, during fresh start of Locus, message is no more visible? But you still see your points database, but no tracks database?


If track database is the only problem, you may try to restore database over Menu > Functions > Backup manager. Maybe you have there some fresh backup that was made automatically on old device. Just keep in mind, that restore of backup overwrite all new data with this backup.

photo
1

What i did it was:


1. copy Locus data folder into PC

2.install locus pro on my new device

3.copy whole Locus folder into my new device data folder

4. run new Locus and get message with wrong directories sqlite databases of tracks... or something, but for sure it has something to do with sqlite and directories in the writing...

5. stop locus

6. run once more and has all data and maps but recorded tracks.


ok, i will repeat all of this today afternoon... and try to do screenshot or write down message...

photo
1

p.s. it is possible if it has something to do with pictures stored in tracks? I can hardly remember that in some tracks i added pictures when i was riding my bike.... the same i made some pois with pictures. It is possible that pictures are stored outside locus data folder...


just idea that came into my mind....

photo
1

Pictures are stored in Locus/data/media folder, but there should be no notification in case, they are missing.


Try re-install Locus and in case, this problem happen again try to create a log for me right after this happen. How to create a log: http://docs.locusmap.eu/doku.php?id=manual:faq:how_to_create_debug_log


Thanks and sorry for a complications.

photo
1

Ok, i will, but not exactly the same....


first i will change Locus base folder to the most upper folder

from: /android/data/menion......./files/locus/)

to just: /locus/

and then copy all of my data...

i dont want to waste time and want to try something different and new.

i did already reinstall and copy once and had the same....

so... i will try make locus folder outside of android data folder, like i had in my old mobile (on sd card)

photo
1

So... it works, but i cannot help you because i set main folder to /sdcard


On my old mobile i had also on sdcard.

on my new i tried copy to default:

/storage/emulated/0/Android/data/menion.android.locus.pro/files

i tried to copy twice, and every time it failed.

when i change main folder to: /sdcard/

and copy whole Locus folder into it, then it works.

I have all of my data, all of my tracks and pois with all data, no problem, no message, all is working now!

So, i will not try to do anything else, sorry. :)

photo
1

Hello,

no problem :). What happen to you is really weird, but to be true, "Locus" in root folder is a lot lot better. Because data in private Android/data/menion... directory, are completely removed when you un-install application. Without any warning!

photo
1

Maybe it has something to do with folder "prefixes" ?

as i can see '/sdcard/' is expanded into '/storage/emulated/0/'

i think if locus would use 'sdcard' folder instead of '/storage/emulated/0/' as default then it would work in my case.

But these are only my speculations :)


edit: i opened file explorer in android and there is no '/0/ folder in 'emulated'! weird!