Import of gpx file with long comments fails

Robert shared this problem 4 years ago
Not a Problem


first of all: I just love Locus. It was actually the reason for me to get an Android tablet.

Problem: Import of gpx file with long comments fails (see attachment for example)

Work around: remove the first line(s) where the Garmin Basecamp Software lists all its bells and whistles. Locus still shows an "Problem with filename.gpx file" message, but tracks and waypoints show up on the map.

Looking for fix: skip such long lines when processing the .gpx file

Thank you for your support,


LG G Pad 8.3

rooted Stock ROM V50020a

Android 4.4.2

Locus Pro 3.0.2

Comments (3)


Good day Robert,

thank you for your report and sorry for an issue.

Unfortunately I'm unable to simulate your problem on my device. May you please check latest BETA version of Locus ( ) , if same problem happen to you with this version? Thank you.

Just short note - long lines (no matter how long), should not cause any issues during import. Break of lines in GPX is optional.


Thank you very much for your swift response!

I tried the attached file again. It fails to load on both my tablet and my phone, if I copy it to /Locus/mapItems and try to open it from Locus, Data, Elements .

Surprisingly, after I clicked the file directly in Total Commander (Locus was not running), the file loaded without any issue. After that, all files that previously failed do also load without issues, regardless whether from /Locus/mapItems or directly from Total Commander. Thus I consider this issue(?) solved.


Hmm it looks like it was in any way incorrectly copied on your devices?

Otherwise I found your file perfectly correct.

If there will be any more problems with import, feel free to write here or create a new issue. Thanks and enjoy Locus ;)