This object is in archive! 

Importing or deleting a Geocache crashes Locus

Josef Rudolf shared this problem 7 years ago
Solved

Hello. Since the newest version, 3.16.0, Locus completely crashes every time I try to import or download (crashes when I click import) one or more geocaches. It also crashes when I try to delete a geocache from the internal Locus database (waypoint folders).

Updating geocache also doesn't work. It simply downloads the listing and then does nothing. Since the problem happens also when deleting geocaches, I suppose it is a problem directly in Locus and not in Geocaching4Locus.

Tried with several different geocaches and waypoint folders, even created a new folder. Nothing works.


Device is Evolveo Strongphone Q8, Android 4.4.4. All the locus data are on SD card (but I think the OS itself thinks it is part of the internal memory).

I didn't manage to collect logs, as the phone is not rooted and catlog doesn't work. But maybe something was sent with the feedback report after the crash.

Replies (7)

photo
1

Good day Josef,


for me it looks like some troubles with write to Locus internal database and it is definitely nothing connected to Geocaching4Locus add-on.


At start, Locus do not warn about some read-write problems with root directory? I'm asking because since Android 4.4, Locus is not able to directly write to SD card, so all data/directory have to be placed in internal memory of device (they are some methods, but generally it is not possible).


It is also possible to obtain log by different method: http://docs.locusmap.eu/doku.php?id=manual:faq:how_to_create_debug_log . Log should be really useful here as error that cause crash of Locus should be really there. Sorry for a troubles and thanks for help with solving ...

photo
1

Hi. Thanks for the answer.

Aside from this topic on helpdesk I also sent a report through the Report button on the crash message. And it should probably contain some automatically attached logs. Did you receive anything? (should be from lugiapathfinder@gmail.com).


And for the SD cart writing.. Some time ago Locus complained on every start that there are several potential Locus data roots, including an unwritable one that was supposed to be on SD card (but in fact was in the internal phone memory). I always chose the correct one on SD card and it worked. I am not sure since when but I don't get this message anymore. The Android on this phone is probably hacked ina way that it thinks SD card is internal memory and internal memory is SD card. It behaves like this in other applications such as Astro file manager or even the camera application.

But all worked fine until now, so I suppose the problem might be something different related to a change in the newest Locus version.

photo
1

Hello, ah perfect. I was able to find your reported issue (thanks to device, email is not visible to me) and here is a content:


Caused by: android.database.sqlite.SQLiteFullException: database or disk is full (code 13)


So seems you have just full SD card :). May you check it please? Thanks

photo
1

Damn.. I feel very stupid now.

Thanks for solving the mystery :) This is why I use SD card, because 32 GB usually doesn't disappear overnight. Probably some dump ocurred, as there is really 0 b free now. There was over 12 GB free recently.


Should I create a feature request for Locus to display a warning instead of crashing when disc is full? :)


Once again thanks. Strange thing is that the Android itself nor any other app complained about zero space yet. I freed some space and now it works as usual.

photo
1

Perfect, glad it helped.


Anyway this is really interesting and I'm more then sure, it has something to do with a method, your device use for work with SD card. Because Locus already have!! such warning in case, free space during start is below 10 MB. But in your case, it obviously wasn't detected. That's why probably no other applications or system complain about it.


So only recommendation - be careful about your free space ;),

photo
2

@ Josef.

32 GB and unexpectedly full ? No warning of (nearly) full SD card ?

I hope you are not victim of the "fake SD Card" business. See google "fake sd card" for more info.

App I use to test all (new) SD cards: "SD insight". https://play.google.com/store/apps/details?id=com.humanlogic.sdi&hl=en

photo
1

Fake SD cards? I haven't heard about that before. Thanks for info.

But in this case it was caused by my own mistake :) Some data got copied there that shouldn't be there. 32 GB of valid data

Replies have been locked on this page!